summaryrefslogtreecommitdiffstats
path: root/dom/webidl/DOMParser.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webidl/DOMParser.webidl
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/DOMParser.webidl')
-rw-r--r--dom/webidl/DOMParser.webidl49
1 files changed, 49 insertions, 0 deletions
diff --git a/dom/webidl/DOMParser.webidl b/dom/webidl/DOMParser.webidl
new file mode 100644
index 0000000000..8c8e62cdbf
--- /dev/null
+++ b/dom/webidl/DOMParser.webidl
@@ -0,0 +1,49 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://domparsing.spec.whatwg.org/#the-domparser-interface
+ */
+
+interface Principal;
+interface URI;
+interface InputStream;
+
+enum SupportedType {
+ "text/html",
+ "text/xml",
+ "application/xml",
+ "application/xhtml+xml",
+ "image/svg+xml"
+};
+
+[Exposed=Window]
+interface DOMParser {
+ [Throws]
+ constructor();
+
+ [NewObject, Throws, UseCounter]
+ Document parseFromString(DOMString str, SupportedType type);
+
+ [NewObject, ChromeOnly, Throws]
+ Document parseFromSafeString(DOMString str, SupportedType type);
+
+ // Mozilla-specific stuff
+ [NewObject, Throws, ChromeOnly]
+ Document parseFromBuffer(sequence<octet> buf, SupportedType type);
+ [NewObject, Throws, ChromeOnly]
+ Document parseFromBuffer(Uint8Array buf, SupportedType type);
+ [NewObject, Throws, ChromeOnly]
+ Document parseFromStream(InputStream stream, DOMString? charset,
+ long contentLength, SupportedType type);
+ // Can be used to allow a DOMParser to parse XUL/XBL no matter what
+ // principal it's using for the document.
+ [ChromeOnly]
+ undefined forceEnableXULXBL();
+
+ // Can be used to allow a DOMParser to load DTDs from URLs that
+ // normally would not be allowed based on the document principal.
+ [Func="IsChromeOrUAWidget"]
+ undefined forceEnableDTD();
+};