summaryrefslogtreecommitdiffstats
path: root/dom/webidl/Element.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /dom/webidl/Element.webidl
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/Element.webidl')
-rw-r--r--dom/webidl/Element.webidl23
1 files changed, 8 insertions, 15 deletions
diff --git a/dom/webidl/Element.webidl b/dom/webidl/Element.webidl
index 32cb1dd30b..bbca476b38 100644
--- a/dom/webidl/Element.webidl
+++ b/dom/webidl/Element.webidl
@@ -4,10 +4,9 @@
* You can obtain one at http://mozilla.org/MPL/2.0/.
*
* The origin of this IDL file is
- * http://dom.spec.whatwg.org/#element and
- * http://domparsing.spec.whatwg.org/ and
- * http://dev.w3.org/csswg/cssom-view/ and
- * http://www.w3.org/TR/selectors-api/
+ * https://dom.spec.whatwg.org/#interface-element
+ * https://domparsing.spec.whatwg.org/
+ * https://drafts.csswg.org/cssom-view/
*
* Copyright © 2012 W3C® (MIT, ERCIM, Keio), All Rights Reserved. W3C
* liability, trademark and document use rules apply.
@@ -112,7 +111,7 @@ interface Element : Node {
* Returns whether this element would be selected by the given selector
* string.
*
- * See <http://dev.w3.org/2006/webapi/selectors-api2/#matchesselector>
+ * https://dom.spec.whatwg.org/#dom-element-matches
*/
[Throws, Pure, BinaryName="matches"]
boolean mozMatchesSelector(UTF8String selector);
@@ -192,7 +191,7 @@ interface mixin ElementCSSInlineStyle {
readonly attribute CSSStyleDeclaration style;
};
-// http://dev.w3.org/csswg/cssom-view/
+// https://drafts.csswg.org/cssom-view/
enum ScrollLogicalPosition { "start", "center", "end", "nearest" };
dictionary ScrollIntoViewOptions : ScrollOptions {
ScrollLogicalPosition block = "start";
@@ -208,7 +207,7 @@ dictionary CheckVisibilityOptions {
[ChromeOnly] boolean flush = true;
};
-// http://dev.w3.org/csswg/cssom-view/#extensions-to-the-element-interface
+// https://drafts.csswg.org/cssom-view/#extensions-to-the-element-interface
partial interface Element {
DOMRectList getClientRects();
DOMRect getBoundingClientRect();
@@ -256,6 +255,8 @@ partial interface Element {
readonly attribute long scrollTopMax;
[ChromeOnly] readonly attribute long scrollLeftMin;
readonly attribute long scrollLeftMax;
+
+ [Pref="layout.css.zoom.enabled"] readonly attribute double currentCSSZoom;
};
// http://domparsing.spec.whatwg.org/#extensions-to-the-element-interface
@@ -268,14 +269,6 @@ partial interface Element {
undefined insertAdjacentHTML(DOMString position, DOMString text);
};
-// http://www.w3.org/TR/selectors-api/#interface-definitions
-partial interface Element {
- [Throws, Pure]
- Element? querySelector(UTF8String selectors);
- [Throws, Pure]
- NodeList querySelectorAll(UTF8String selectors);
-};
-
// https://dom.spec.whatwg.org/#dictdef-shadowrootinit
dictionary ShadowRootInit {
required ShadowRootMode mode;