summaryrefslogtreecommitdiffstats
path: root/dom/webidl/FormDataEvent.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webidl/FormDataEvent.webidl
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/FormDataEvent.webidl')
-rw-r--r--dom/webidl/FormDataEvent.webidl21
1 files changed, 21 insertions, 0 deletions
diff --git a/dom/webidl/FormDataEvent.webidl b/dom/webidl/FormDataEvent.webidl
new file mode 100644
index 0000000000..100e21c75e
--- /dev/null
+++ b/dom/webidl/FormDataEvent.webidl
@@ -0,0 +1,21 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/form-control-infrastructure.html#the-formdataevent-interface
+ */
+
+[Exposed=Window]
+interface FormDataEvent : Event {
+ constructor(DOMString type, optional FormDataEventInit eventInitDict = {});
+
+ // C++ can't deal with a method called FormData() in the generated code
+ [BinaryName="GetFormData"]
+ readonly attribute FormData formData;
+};
+
+dictionary FormDataEventInit : EventInit {
+ required FormData formData;
+};