summaryrefslogtreecommitdiffstats
path: root/dom/webidl/NonElementParentNode.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /dom/webidl/NonElementParentNode.webidl
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/NonElementParentNode.webidl')
-rw-r--r--dom/webidl/NonElementParentNode.webidl12
1 files changed, 12 insertions, 0 deletions
diff --git a/dom/webidl/NonElementParentNode.webidl b/dom/webidl/NonElementParentNode.webidl
new file mode 100644
index 0000000000..574fb07cc7
--- /dev/null
+++ b/dom/webidl/NonElementParentNode.webidl
@@ -0,0 +1,12 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://dom.spec.whatwg.org/#nonelementparentnode
+ */
+interface mixin NonElementParentNode {
+ [Pure]
+ Element? getElementById(DOMString elementId);
+};