summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ParentNode.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webidl/ParentNode.webidl
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/ParentNode.webidl')
-rw-r--r--dom/webidl/ParentNode.webidl33
1 files changed, 33 insertions, 0 deletions
diff --git a/dom/webidl/ParentNode.webidl b/dom/webidl/ParentNode.webidl
new file mode 100644
index 0000000000..4350fb8a05
--- /dev/null
+++ b/dom/webidl/ParentNode.webidl
@@ -0,0 +1,33 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://dom.spec.whatwg.org/#interface-parentnode
+ */
+
+interface mixin ParentNode {
+ [Constant]
+ readonly attribute HTMLCollection children;
+ [Pure]
+ readonly attribute Element? firstElementChild;
+ [Pure]
+ readonly attribute Element? lastElementChild;
+ [Pure]
+ readonly attribute unsigned long childElementCount;
+
+ [ChromeOnly]
+ HTMLCollection getElementsByAttribute(DOMString name,
+ [LegacyNullToEmptyString] DOMString value);
+ [ChromeOnly, Throws]
+ HTMLCollection getElementsByAttributeNS(DOMString? namespaceURI, DOMString name,
+ [LegacyNullToEmptyString] DOMString value);
+
+ [CEReactions, Throws, Unscopable]
+ undefined prepend((Node or DOMString)... nodes);
+ [CEReactions, Throws, Unscopable]
+ undefined append((Node or DOMString)... nodes);
+ [CEReactions, Throws, Unscopable]
+ undefined replaceChildren((Node or DOMString)... nodes);
+};