summaryrefslogtreecommitdiffstats
path: root/dom/webidl/Request.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webidl/Request.webidl
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/Request.webidl')
-rw-r--r--dom/webidl/Request.webidl82
1 files changed, 82 insertions, 0 deletions
diff --git a/dom/webidl/Request.webidl b/dom/webidl/Request.webidl
new file mode 100644
index 0000000000..1aa6be963f
--- /dev/null
+++ b/dom/webidl/Request.webidl
@@ -0,0 +1,82 @@
+/* -*- Mode: IDL; tab-width: 1; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://fetch.spec.whatwg.org/#request-class
+ */
+
+typedef (Request or USVString) RequestInfo;
+typedef unsigned long nsContentPolicyType;
+
+[Exposed=(Window,Worker)]
+interface Request {
+ [Throws]
+ constructor(RequestInfo input, optional RequestInit init = {});
+
+ readonly attribute ByteString method;
+ readonly attribute USVString url;
+ [SameObject, BinaryName="headers_"] readonly attribute Headers headers;
+
+ readonly attribute RequestDestination destination;
+ readonly attribute USVString referrer;
+ [BinaryName="referrerPolicy_"]
+ readonly attribute ReferrerPolicy referrerPolicy;
+ readonly attribute RequestMode mode;
+ readonly attribute RequestCredentials credentials;
+ readonly attribute RequestCache cache;
+ readonly attribute RequestRedirect redirect;
+ readonly attribute DOMString integrity;
+
+ // If a main-thread fetch() promise rejects, the error passed will be a
+ // nsresult code.
+ [ChromeOnly]
+ readonly attribute boolean mozErrors;
+
+ [BinaryName="getOrCreateSignal"]
+ readonly attribute AbortSignal signal;
+
+ [Throws,
+ NewObject] Request clone();
+
+ // Bug 1124638 - Allow chrome callers to set the context.
+ [ChromeOnly]
+ undefined overrideContentPolicyType(nsContentPolicyType context);
+};
+Request includes Body;
+
+// <https://fetch.spec.whatwg.org/#requestinit>.
+dictionary RequestInit {
+ ByteString method;
+ HeadersInit headers;
+ BodyInit? body;
+ USVString referrer;
+ ReferrerPolicy referrerPolicy;
+ RequestMode mode;
+ RequestCredentials credentials;
+ RequestCache cache;
+ RequestRedirect redirect;
+ DOMString integrity;
+
+ [ChromeOnly]
+ boolean mozErrors;
+
+ AbortSignal? signal;
+
+ [Pref="dom.fetchObserver.enabled"]
+ ObserverCallback observe;
+};
+
+enum RequestDestination {
+ "",
+ "audio", "audioworklet", "document", "embed", "font", "frame", "iframe",
+ "image", "manifest", "object", "paintworklet", "report", "script",
+ "sharedworker", "style", "track", "video", "worker", "xslt"
+};
+
+enum RequestMode { "same-origin", "no-cors", "cors", "navigate" };
+enum RequestCredentials { "omit", "same-origin", "include" };
+enum RequestCache { "default", "no-store", "reload", "no-cache", "force-cache", "only-if-cached" };
+enum RequestRedirect { "follow", "error", "manual" };
+enum RequestPriority { "high" , "low" , "auto" };