summaryrefslogtreecommitdiffstats
path: root/dom/webidl/WritableStreamDefaultWriter.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webidl/WritableStreamDefaultWriter.webidl
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webidl/WritableStreamDefaultWriter.webidl')
-rw-r--r--dom/webidl/WritableStreamDefaultWriter.webidl29
1 files changed, 29 insertions, 0 deletions
diff --git a/dom/webidl/WritableStreamDefaultWriter.webidl b/dom/webidl/WritableStreamDefaultWriter.webidl
new file mode 100644
index 0000000000..e033079f04
--- /dev/null
+++ b/dom/webidl/WritableStreamDefaultWriter.webidl
@@ -0,0 +1,29 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#default-writer-class-definition
+ */
+
+[Exposed=*]
+interface WritableStreamDefaultWriter {
+ [Throws]
+ constructor(WritableStream stream);
+
+ readonly attribute Promise<undefined> closed;
+ [Throws] readonly attribute unrestricted double? desiredSize;
+ readonly attribute Promise<undefined> ready;
+
+ [Throws]
+ Promise<undefined> abort(optional any reason);
+
+ [NewObject]
+ Promise<undefined> close();
+
+ undefined releaseLock();
+
+ [NewObject]
+ Promise<undefined> write(optional any chunk);
+};