summaryrefslogtreecommitdiffstats
path: root/intl/encoding_glue/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /intl/encoding_glue/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'intl/encoding_glue/Cargo.toml')
-rw-r--r--intl/encoding_glue/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/intl/encoding_glue/Cargo.toml b/intl/encoding_glue/Cargo.toml
new file mode 100644
index 0000000000..83c78315d9
--- /dev/null
+++ b/intl/encoding_glue/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "encoding_glue"
+description = "FFI functions for mozilla::Encoding that aren't appropriate to share on crates.io due to m-c dependencies"
+version = "0.1.0"
+authors = ["Henri Sivonen <hsivonen@hsivonen.fi>"]
+license = "MIT/Apache-2.0"
+
+[features]
+simd-accel = ["encoding_rs/simd-accel"]
+
+[dependencies]
+encoding_rs = "0.8.0"
+nsstring = { path = "../../xpcom/rust/nsstring" }
+nserror = { path = "../../xpcom/rust/nserror" }
+xmldecl = "0.2.0"