summaryrefslogtreecommitdiffstats
path: root/intl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /intl
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'intl')
-rw-r--r--intl/bidi/rust/unicode-bidi-ffi/Cargo.toml2
-rw-r--r--intl/locale/mac/OSPreferences_mac.cpp3
-rw-r--r--intl/locale/moz.build2
-rw-r--r--intl/locale/mozILocaleService.idl8
-rw-r--r--intl/locale/mozIOSPreferences.idl8
-rw-r--r--intl/uconv/nsConverterInputStream.cpp2
-rw-r--r--intl/uconv/nsIScriptableUConv.idl6
-rw-r--r--intl/uconv/nsITextToSubURI.idl2
-rw-r--r--intl/unicharutil/util/ICUUtils.cpp1
9 files changed, 6 insertions, 28 deletions
diff --git a/intl/bidi/rust/unicode-bidi-ffi/Cargo.toml b/intl/bidi/rust/unicode-bidi-ffi/Cargo.toml
index 9c39fc07e1..b357fdd725 100644
--- a/intl/bidi/rust/unicode-bidi-ffi/Cargo.toml
+++ b/intl/bidi/rust/unicode-bidi-ffi/Cargo.toml
@@ -6,5 +6,5 @@ authors = ["Jonathan Kew <jkew@mozilla.com>"]
edition = "2021"
[dependencies]
-unicode-bidi = "0.3.14"
+unicode-bidi = { version = "0.3.15", features = ["smallvec"] }
icu_properties = { version = "1.4.0", features = ["bidi"] }
diff --git a/intl/locale/mac/OSPreferences_mac.cpp b/intl/locale/mac/OSPreferences_mac.cpp
index f8cd910b40..ddd0a41e03 100644
--- a/intl/locale/mac/OSPreferences_mac.cpp
+++ b/intl/locale/mac/OSPreferences_mac.cpp
@@ -6,7 +6,8 @@
#include "OSPreferences.h"
#include "mozilla/intl/LocaleService.h"
-#include <Carbon/Carbon.h>
+#include <CoreFoundation/CoreFoundation.h>
+#include <CoreText/CoreText.h>
using namespace mozilla::intl;
diff --git a/intl/locale/moz.build b/intl/locale/moz.build
index 8099d1a695..10e7c5cfb1 100644
--- a/intl/locale/moz.build
+++ b/intl/locale/moz.build
@@ -14,7 +14,7 @@ toolkit = CONFIG["MOZ_WIDGET_TOOLKIT"]
if toolkit == "windows":
DIRS += ["windows"]
-elif toolkit == "cocoa":
+elif toolkit in ("cocoa", "uikit"):
DIRS += ["mac"]
elif toolkit == "gtk":
DIRS += ["gtk"]
diff --git a/intl/locale/mozILocaleService.idl b/intl/locale/mozILocaleService.idl
index 71227a64d3..0cf027caea 100644
--- a/intl/locale/mozILocaleService.idl
+++ b/intl/locale/mozILocaleService.idl
@@ -5,14 +5,6 @@
#include "nsISupports.idl"
-%{C++
-// Define Contractid and CID
-#define MOZ_LOCALESERVICE_CID \
- { 0x92735ff4, 0x6384, 0x4ad6, { 0x85, 0x08, 0x75, 0x70, 0x10, 0xe1, 0x49, 0xee } }
-
-#define MOZ_LOCALESERVICE_CONTRACTID "@mozilla.org/intl/localeservice;1"
-%}
-
[scriptable, uuid(C27F8983-B48B-4D1A-92D7-FEB8106F212D)]
interface mozILocaleService : nsISupports
{
diff --git a/intl/locale/mozIOSPreferences.idl b/intl/locale/mozIOSPreferences.idl
index f3e1c12440..1664aabfbe 100644
--- a/intl/locale/mozIOSPreferences.idl
+++ b/intl/locale/mozIOSPreferences.idl
@@ -5,14 +5,6 @@
#include "nsISupports.idl"
-%{C++
-// Define Contractid and CID
-#define MOZ_OSPREFERENCES_CID \
- { 0x65944815, 0xe9ae, 0x48bd, { 0xa2, 0xbf, 0xf1, 0x10, 0x87, 0x20, 0x95, 0x0c } }
-
-#define MOZ_OSPREFERENCES_CONTRACTID "@mozilla.org/intl/ospreferences;1"
-%}
-
[scriptable, uuid(65944815-e9ae-48bd-a2bf-f1108720950c)]
interface mozIOSPreferences : nsISupports
{
diff --git a/intl/uconv/nsConverterInputStream.cpp b/intl/uconv/nsConverterInputStream.cpp
index e3efdbc146..96fad345b2 100644
--- a/intl/uconv/nsConverterInputStream.cpp
+++ b/intl/uconv/nsConverterInputStream.cpp
@@ -42,7 +42,7 @@ nsConverterInputStream::Init(nsIInputStream* aStream, const char* aCharset,
aBufferSize = CONVERTER_BUFFER_SIZE;
outputBufferSize = CONVERTER_BUFFER_SIZE;
} else {
- // NetUtil.jsm assumes that if buffer size equals
+ // NetUtil.sys.mjs assumes that if buffer size equals
// the input size, the whole stream will be processed
// as one readString. This is not true with encoding_rs,
// because encoding_rs might want to see space for a
diff --git a/intl/uconv/nsIScriptableUConv.idl b/intl/uconv/nsIScriptableUConv.idl
index 7f1334c0c3..8dc59ae1db 100644
--- a/intl/uconv/nsIScriptableUConv.idl
+++ b/intl/uconv/nsIScriptableUConv.idl
@@ -7,12 +7,6 @@
interface nsIInputStream;
-%{C++
-// {0A698C44-3BFF-11d4-9649-00C0CA135B4E}
-#define NS_ISCRIPTABLEUNICODECONVERTER_CID { 0x0A698C44, 0x3BFF, 0x11d4, { 0x96, 0x49, 0x00, 0xC0, 0xCA, 0x13, 0x5B, 0x4E } }
-#define NS_ISCRIPTABLEUNICODECONVERTER_CONTRACTID "@mozilla.org/intl/scriptableunicodeconverter"
-%}
-
/**
* In new code, please use the WebIDL TextDecoder and TextEncoder
* instead. They represent bytes as Uint8Array (or as view to such
diff --git a/intl/uconv/nsITextToSubURI.idl b/intl/uconv/nsITextToSubURI.idl
index 3bb404e414..7e0d598477 100644
--- a/intl/uconv/nsITextToSubURI.idl
+++ b/intl/uconv/nsITextToSubURI.idl
@@ -7,8 +7,6 @@
%{C++
-// {8B042E22-6F87-11d3-B3C8-00805F8A6670}
-#define NS_TEXTTOSUBURI_CID { 0x8b042e22, 0x6f87, 0x11d3, { 0xb3, 0xc8, 0x0, 0x80, 0x5f, 0x8a, 0x66, 0x70 } }
#define NS_ITEXTTOSUBURI_CONTRACTID "@mozilla.org/intl/texttosuburi;1"
%}
diff --git a/intl/unicharutil/util/ICUUtils.cpp b/intl/unicharutil/util/ICUUtils.cpp
index ea3579f27c..2c3099c86a 100644
--- a/intl/unicharutil/util/ICUUtils.cpp
+++ b/intl/unicharutil/util/ICUUtils.cpp
@@ -8,6 +8,7 @@
# include "mozilla/UniquePtr.h"
# include "ICUUtils.h"
+# include "mozilla/ClearOnShutdown.h"
# include "mozilla/StaticPrefs_dom.h"
# include "mozilla/intl/LocaleService.h"
# include "mozilla/intl/FormatBuffer.h"