summaryrefslogtreecommitdiffstats
path: root/js/src/fuzz-tests
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
commit8dd16259287f58f9273002717ec4d27e97127719 (patch)
tree3863e62a53829a84037444beab3abd4ed9dfc7d0 /js/src/fuzz-tests
parentReleasing progress-linux version 126.0.1-1~progress7.99u1. (diff)
downloadfirefox-8dd16259287f58f9273002717ec4d27e97127719.tar.xz
firefox-8dd16259287f58f9273002717ec4d27e97127719.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'js/src/fuzz-tests')
-rw-r--r--js/src/fuzz-tests/gluesmith/Cargo.toml2
-rw-r--r--js/src/fuzz-tests/moz.build7
-rw-r--r--js/src/fuzz-tests/tests.cpp1
3 files changed, 6 insertions, 4 deletions
diff --git a/js/src/fuzz-tests/gluesmith/Cargo.toml b/js/src/fuzz-tests/gluesmith/Cargo.toml
index c5f7118ba4..d22ac49f2e 100644
--- a/js/src/fuzz-tests/gluesmith/Cargo.toml
+++ b/js/src/fuzz-tests/gluesmith/Cargo.toml
@@ -5,6 +5,6 @@ authors = ["Christian Holler"]
license = "MPL-2.0"
[dependencies]
-wasm-smith = "0.201.0"
+wasm-smith = "0.205.0"
arbitrary = { version = "1.0.0", features = ["derive"] }
libc = "0.2"
diff --git a/js/src/fuzz-tests/moz.build b/js/src/fuzz-tests/moz.build
index ccec998f0b..89f16e681f 100644
--- a/js/src/fuzz-tests/moz.build
+++ b/js/src/fuzz-tests/moz.build
@@ -33,9 +33,10 @@ if CONFIG["FUZZING"]:
include("/tools/fuzzing/libfuzzer-config.mozbuild")
if CONFIG["FUZZING_INTERFACES"]:
- USE_LIBS += [
- "static:fuzzer",
- ]
+ if CONFIG["LIBFUZZER"]:
+ USE_LIBS += ["static:fuzzer"]
+ else:
+ USE_LIBS += ["static:fuzzer-interface"]
USE_LIBS += [
"static:js",
diff --git a/js/src/fuzz-tests/tests.cpp b/js/src/fuzz-tests/tests.cpp
index 408920eecc..7b288bec9a 100644
--- a/js/src/fuzz-tests/tests.cpp
+++ b/js/src/fuzz-tests/tests.cpp
@@ -12,6 +12,7 @@
#include "js/GlobalObject.h"
#include "js/Initialization.h"
#include "js/Prefs.h"
+#include "js/RealmOptions.h"
#include "js/RootingAPI.h"
#include "js/Stack.h"
#include "vm/JSContext.h"