summaryrefslogtreecommitdiffstats
path: root/js/src/rust/shared
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /js/src/rust/shared
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'js/src/rust/shared')
-rw-r--r--js/src/rust/shared/Cargo.toml30
-rw-r--r--js/src/rust/shared/lib.rs27
2 files changed, 57 insertions, 0 deletions
diff --git a/js/src/rust/shared/Cargo.toml b/js/src/rust/shared/Cargo.toml
new file mode 100644
index 0000000000..e3218354be
--- /dev/null
+++ b/js/src/rust/shared/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "jsrust_shared"
+version = "0.1.0"
+authors = ["The Spidermonkey developers"]
+license = "MPL-2.0"
+
+[lib]
+crate-type = ["rlib"]
+name = "jsrust_shared"
+path = "lib.rs"
+
+[dependencies]
+encoding_c = "0.9.5"
+encoding_c_mem = "0.2.4"
+smoosh = { path = "../../frontend/smoosh", optional = true }
+mozglue-static = { path = "../../../../mozglue/static/rust" }
+gluesmith = { path = "../../fuzz-tests/gluesmith", optional = true }
+icu_capi = { version = "1.4.0", optional = true, default-features= false, features = ["any_provider", "compiled_data", "icu_segmenter"] }
+unicode-bidi-ffi = { path = "../../../../intl/bidi/rust/unicode-bidi-ffi" }
+
+[features]
+simd-accel = ['encoding_c/simd-accel']
+icu4x = ['icu_capi']
+
+# Uncomment this to enable perf support in release mode.
+#[profile.release]
+#debug = true
+
+[package.metadata.cargo-udeps.ignore]
+normal = ["mozilla-central-workspace-hack"]
diff --git a/js/src/rust/shared/lib.rs b/js/src/rust/shared/lib.rs
new file mode 100644
index 0000000000..5ebecde26f
--- /dev/null
+++ b/js/src/rust/shared/lib.rs
@@ -0,0 +1,27 @@
+/* Copyright 2018 Mozilla Foundation
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+extern crate encoding_c;
+extern crate encoding_c_mem;
+extern crate mozglue_static;
+extern crate unicode_bidi_ffi;
+
+#[cfg(feature = "smoosh")]
+extern crate smoosh;
+
+#[cfg(feature = "gluesmith")]
+extern crate gluesmith;
+
+#[cfg(feature = "icu4x")]
+extern crate icu_capi;