summaryrefslogtreecommitdiffstats
path: root/layout/style/res
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /layout/style/res
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'layout/style/res')
-rw-r--r--layout/style/res/forms.css4
-rw-r--r--layout/style/res/html.css12
2 files changed, 13 insertions, 3 deletions
diff --git a/layout/style/res/forms.css b/layout/style/res/forms.css
index 587534e9f3..044d460ad4 100644
--- a/layout/style/res/forms.css
+++ b/layout/style/res/forms.css
@@ -73,6 +73,8 @@ fieldset {
label {
cursor: default;
+ /* If you add declarations here, consider whether the select > label and file
+ * input label need them as well. */
}
/* Default inputs, text inputs, and selects */
@@ -281,6 +283,7 @@ select > button {
select > label {
display: inline-block;
overflow: clip;
+ cursor: unset;
}
option[label]::before {
@@ -627,6 +630,7 @@ input[type=file] > label {
min-inline-size: 12em;
text-align: match-parent;
+ cursor: unset;
color: unset;
font-size: unset;
letter-spacing: unset;
diff --git a/layout/style/res/html.css b/layout/style/res/html.css
index ff58ecd4d1..18dd1c4855 100644
--- a/layout/style/res/html.css
+++ b/layout/style/res/html.css
@@ -765,7 +765,7 @@ video > .caption-box {
* The pseudo element won't inherit CSS styles from its direct parent, `::cue`
* would actually inherit styles from video because it's video's pseudo element.
* Therefore, we have to explicitly set some styles which are already defined
- * in its parent element in vtt.jsm.
+ * in its parent element in vtt.sys.mjs.
*/
::cue {
color: rgba(255, 255, 255, 1);
@@ -816,15 +816,21 @@ dialog::backdrop {
background: rgba(0, 0, 0, 0.1);
}
+/* https://html.spec.whatwg.org/#the-marquee-element-2 */
marquee {
- inline-size: -moz-available;
display: inline-block;
+ text-align: initial;
+ overflow: hidden !important;
+
+ /* See https://github.com/whatwg/html/issues/10249 */
+ inline-size: -moz-available;
vertical-align: text-bottom;
- text-align: start;
+ white-space: nowrap;
}
marquee:is([direction="up"], [direction="down"]) {
block-size: 200px;
+ white-space: unset;
}
/* Ruby */