summaryrefslogtreecommitdiffstats
path: root/netwerk/test/http3server
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:34:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:34:50 +0000
commitdef92d1b8e9d373e2f6f27c366d578d97d8960c6 (patch)
tree2ef34b9ad8bb9a9220e05d60352558b15f513894 /netwerk/test/http3server
parentAdding debian version 125.0.3-1. (diff)
downloadfirefox-def92d1b8e9d373e2f6f27c366d578d97d8960c6.tar.xz
firefox-def92d1b8e9d373e2f6f27c366d578d97d8960c6.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'netwerk/test/http3server')
-rw-r--r--netwerk/test/http3server/Cargo.toml10
-rw-r--r--netwerk/test/http3server/src/main.rs2
2 files changed, 6 insertions, 6 deletions
diff --git a/netwerk/test/http3server/Cargo.toml b/netwerk/test/http3server/Cargo.toml
index 60ff22c530..4905760d3d 100644
--- a/netwerk/test/http3server/Cargo.toml
+++ b/netwerk/test/http3server/Cargo.toml
@@ -6,10 +6,10 @@ edition = "2018"
license = "MPL-2.0"
[dependencies]
-neqo-transport = { tag = "v0.7.2", git = "https://github.com/mozilla/neqo" }
-neqo-common = { tag = "v0.7.2", git = "https://github.com/mozilla/neqo" }
-neqo-http3 = { tag = "v0.7.2", git = "https://github.com/mozilla/neqo" }
-neqo-qpack = { tag = "v0.7.2", git = "https://github.com/mozilla/neqo" }
+neqo-transport = { tag = "v0.7.5", git = "https://github.com/mozilla/neqo" }
+neqo-common = { tag = "v0.7.5", git = "https://github.com/mozilla/neqo" }
+neqo-http3 = { tag = "v0.7.5", git = "https://github.com/mozilla/neqo" }
+neqo-qpack = { tag = "v0.7.5", git = "https://github.com/mozilla/neqo" }
mio = "0.6.17"
mio-extras = "2.0.5"
log = "0.4.0"
@@ -21,7 +21,7 @@ tokio = { version = "1", features = ["rt-multi-thread"] }
mozilla-central-workspace-hack = { version = "0.1", features = ["http3server"], optional = true }
[dependencies.neqo-crypto]
-tag = "v0.7.2"
+tag = "v0.7.5"
git = "https://github.com/mozilla/neqo"
default-features = false
features = ["gecko"]
diff --git a/netwerk/test/http3server/src/main.rs b/netwerk/test/http3server/src/main.rs
index a308f56442..1543e3aeb3 100644
--- a/netwerk/test/http3server/src/main.rs
+++ b/netwerk/test/http3server/src/main.rs
@@ -1378,7 +1378,7 @@ fn main() -> Result<(), io::Error> {
}
});
- init_db(PathBuf::from(args[1].clone()));
+ init_db(PathBuf::from(args[1].clone())).unwrap();
let mut servers_runner = ServersRunner::new()?;
servers_runner.init();