summaryrefslogtreecommitdiffstats
path: root/netwerk/test/unit_ipc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /netwerk/test/unit_ipc
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'netwerk/test/unit_ipc')
-rw-r--r--netwerk/test/unit_ipc/child_veto_in_parent.js2
-rw-r--r--netwerk/test/unit_ipc/test_alt-data_cross_process_wrap.js2
-rw-r--r--netwerk/test/unit_ipc/test_channel_id.js2
-rw-r--r--netwerk/test/unit_ipc/test_gio_protocol_wrap.js2
-rw-r--r--netwerk/test/unit_ipc/test_httpcancel_wrap.js2
-rw-r--r--netwerk/test/unit_ipc/xpcshell.toml1
6 files changed, 6 insertions, 5 deletions
diff --git a/netwerk/test/unit_ipc/child_veto_in_parent.js b/netwerk/test/unit_ipc/child_veto_in_parent.js
index 8f922a254e..f1bc0a4f50 100644
--- a/netwerk/test/unit_ipc/child_veto_in_parent.js
+++ b/netwerk/test/unit_ipc/child_veto_in_parent.js
@@ -18,7 +18,7 @@ ChromeUtils.defineLazyGetter(this, "randomURI", function () {
return URL + randomPath;
});
-function make_channel(url, callback, ctx) {
+function make_channel(url) {
return NetUtil.newChannel({ uri: url, loadUsingSystemPrincipal: true });
}
diff --git a/netwerk/test/unit_ipc/test_alt-data_cross_process_wrap.js b/netwerk/test/unit_ipc/test_alt-data_cross_process_wrap.js
index 336b9e3129..07c3e8398a 100644
--- a/netwerk/test/unit_ipc/test_alt-data_cross_process_wrap.js
+++ b/netwerk/test/unit_ipc/test_alt-data_cross_process_wrap.js
@@ -41,7 +41,7 @@ function load_channel(channelUrl) {
chan.asyncOpen(new ChannelListener(readTextData, null));
}
-function make_channel(channelUrl, callback, ctx) {
+function make_channel(channelUrl) {
return NetUtil.newChannel({
uri: channelUrl,
loadUsingSystemPrincipal: true,
diff --git a/netwerk/test/unit_ipc/test_channel_id.js b/netwerk/test/unit_ipc/test_channel_id.js
index fc37651249..1031dba4e2 100644
--- a/netwerk/test/unit_ipc/test_channel_id.js
+++ b/netwerk/test/unit_ipc/test_channel_id.js
@@ -47,7 +47,7 @@ let parentChannelsDone = new Promise(resolve => {
};
});
-function observer(subject, topic, data) {
+function observer(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
let uri = channel.URI.spec;
diff --git a/netwerk/test/unit_ipc/test_gio_protocol_wrap.js b/netwerk/test/unit_ipc/test_gio_protocol_wrap.js
index f6aa6b83e8..e6e2c42bc2 100644
--- a/netwerk/test/unit_ipc/test_gio_protocol_wrap.js
+++ b/netwerk/test/unit_ipc/test_gio_protocol_wrap.js
@@ -9,7 +9,7 @@ function run_test() {
"localtest:,recent:"
);
- do_await_remote_message("gio-allow-test-protocols").then(port => {
+ do_await_remote_message("gio-allow-test-protocols").then(() => {
do_send_remote_message("gio-allow-test-protocols-done");
});
diff --git a/netwerk/test/unit_ipc/test_httpcancel_wrap.js b/netwerk/test/unit_ipc/test_httpcancel_wrap.js
index f56d0e198b..3e54171ede 100644
--- a/netwerk/test/unit_ipc/test_httpcancel_wrap.js
+++ b/netwerk/test/unit_ipc/test_httpcancel_wrap.js
@@ -13,7 +13,7 @@ function run_test() {
observer = {
QueryInterface: ChromeUtils.generateQI(["nsIObserver"]),
- observe(subject, topic, data) {
+ observe(subject) {
subject = subject.QueryInterface(Ci.nsIRequest);
subject.cancel(Cr.NS_BINDING_ABORTED);
diff --git a/netwerk/test/unit_ipc/xpcshell.toml b/netwerk/test/unit_ipc/xpcshell.toml
index 569bcda751..24c84d745d 100644
--- a/netwerk/test/unit_ipc/xpcshell.toml
+++ b/netwerk/test/unit_ipc/xpcshell.toml
@@ -153,6 +153,7 @@ run-sequentially = "http3server"
skip-if = [
"os == 'android'",
"os == 'win' && msix",
+ "true", # Will be reenabled in bug 1865394
] # https://bugzilla.mozilla.org/show_bug.cgi?id=1807925
run-sequentially = "http3server"