summaryrefslogtreecommitdiffstats
path: root/old-configure.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
commit8dd16259287f58f9273002717ec4d27e97127719 (patch)
tree3863e62a53829a84037444beab3abd4ed9dfc7d0 /old-configure.in
parentReleasing progress-linux version 126.0.1-1~progress7.99u1. (diff)
downloadfirefox-8dd16259287f58f9273002717ec4d27e97127719.tar.xz
firefox-8dd16259287f58f9273002717ec4d27e97127719.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'old-configure.in')
-rw-r--r--old-configure.in30
1 files changed, 4 insertions, 26 deletions
diff --git a/old-configure.in b/old-configure.in
index 83464f9319..218048fa73 100644
--- a/old-configure.in
+++ b/old-configure.in
@@ -49,8 +49,9 @@ dnl ========================================================
if test "$COMPILE_ENVIRONMENT"; then
-# Run some logic to figure out exe extensions (mostly for mingw's sake)
-AC_EXEEXT
+# This prevents mingw from adding .exe when generating executable. Internal use
+# only.
+ac_exeext=.out
if test "$target" != "$host"; then
MOZ_CROSS_COMPILER
@@ -274,24 +275,7 @@ case "$target" in
;;
*-android*|*-linuxandroid*)
- # From https://github.com/android-ndk/ndk/issues/133#issuecomment-308549264
- # -Oz is smaller than -Os on clang.
- MOZ_OPTIMIZE_FLAGS="-Oz"
- # Disable the outliner, which causes performance regressions, and is
- # enabled on some platforms at -Oz.
- if test -z "$MOZ_LTO"; then
- DISABLE_OUTLINER="-mno-outline"
- _SAVE_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS $DISABLE_OUTLINER"
- AC_TRY_COMPILE(,,[MOZ_OPTIMIZE_FLAGS="$MOZ_OPTIMIZE_FLAGS $DISABLE_OUTLINER"])
- CFLAGS="$_SAVE_CFLAGS"
- else
- DISABLE_OUTLINER="-Wl,-plugin-opt=-enable-machine-outliner=never"
- _SAVE_LDFLAGS=$LDFLAGS
- LDFLAGS="$LDFLAGS $MOZ_LTO_LDFLAGS $DISABLE_OUTLINER"
- AC_TRY_LINK(,,[MOZ_OPTIMIZE_LDFLAGS="$MOZ_OPTIMIZE_LDFLAGS $DISABLE_OUTLINER"])
- LDFLAGS="$_SAVE_LDFLAGS"
- fi
+ MOZ_OPTIMIZE_FLAGS="-O2"
;;
*-*linux*)
@@ -831,12 +815,6 @@ MOZ_EXPAND_LIBS
fi # COMPILE_ENVIRONMENT
dnl ========================================================
-dnl Check if we need the 32-bit Linux SSE2 error dialog
-dnl ========================================================
-
-AC_SUBST(MOZ_LINUX_32_SSE2_STARTUP_ERROR)
-
-dnl ========================================================
dnl Check for cairo
dnl ========================================================