summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/packages/browsers/test/src/firefox/firefox-data.spec.ts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /remote/test/puppeteer/packages/browsers/test/src/firefox/firefox-data.spec.ts
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/test/puppeteer/packages/browsers/test/src/firefox/firefox-data.spec.ts')
-rw-r--r--remote/test/puppeteer/packages/browsers/test/src/firefox/firefox-data.spec.ts97
1 files changed, 97 insertions, 0 deletions
diff --git a/remote/test/puppeteer/packages/browsers/test/src/firefox/firefox-data.spec.ts b/remote/test/puppeteer/packages/browsers/test/src/firefox/firefox-data.spec.ts
new file mode 100644
index 0000000000..d0bb056090
--- /dev/null
+++ b/remote/test/puppeteer/packages/browsers/test/src/firefox/firefox-data.spec.ts
@@ -0,0 +1,97 @@
+/**
+ * @license
+ * Copyright 2023 Google Inc.
+ * SPDX-License-Identifier: Apache-2.0
+ */
+
+import assert from 'assert';
+import fs from 'fs';
+import os from 'os';
+import path from 'path';
+
+import {BrowserPlatform} from '../../../lib/cjs/browser-data/browser-data.js';
+import {
+ createProfile,
+ relativeExecutablePath,
+ resolveDownloadUrl,
+} from '../../../lib/cjs/browser-data/firefox.js';
+
+describe('Firefox', () => {
+ it('should resolve download URLs', () => {
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.LINUX, '111.0a1'),
+ 'https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-111.0a1.en-US.linux-x86_64.tar.bz2'
+ );
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.MAC, '111.0a1'),
+ 'https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-111.0a1.en-US.mac.dmg'
+ );
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.MAC_ARM, '111.0a1'),
+ 'https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-111.0a1.en-US.mac.dmg'
+ );
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.WIN32, '111.0a1'),
+ 'https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-111.0a1.en-US.win32.zip'
+ );
+ assert.strictEqual(
+ resolveDownloadUrl(BrowserPlatform.WIN64, '111.0a1'),
+ 'https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/firefox-111.0a1.en-US.win64.zip'
+ );
+ });
+
+ it('should resolve executable paths', () => {
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.LINUX, '111.0a1'),
+ path.join('firefox', 'firefox')
+ );
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.MAC, '111.0a1'),
+ path.join('Firefox Nightly.app', 'Contents', 'MacOS', 'firefox')
+ );
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.MAC_ARM, '111.0a1'),
+ path.join('Firefox Nightly.app', 'Contents', 'MacOS', 'firefox')
+ );
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.WIN32, '111.0a1'),
+ path.join('firefox', 'firefox.exe')
+ );
+ assert.strictEqual(
+ relativeExecutablePath(BrowserPlatform.WIN64, '111.0a1'),
+ path.join('firefox', 'firefox.exe')
+ );
+ });
+
+ describe('profile', () => {
+ let tmpDir = '/tmp/puppeteer-browsers-test';
+
+ beforeEach(() => {
+ tmpDir = fs.mkdtempSync(
+ path.join(os.tmpdir(), 'puppeteer-browsers-test')
+ );
+ });
+
+ afterEach(() => {
+ fs.rmSync(tmpDir, {
+ force: true,
+ recursive: true,
+ maxRetries: 5,
+ });
+ });
+
+ it('should create a profile', async () => {
+ await createProfile({
+ preferences: {
+ test: 1,
+ },
+ path: tmpDir,
+ });
+ const text = fs.readFileSync(path.join(tmpDir, 'user.js'), 'utf-8');
+ assert.ok(
+ text.includes(`user_pref("toolkit.startup.max_resumed_crashes", -1);`)
+ ); // default preference.
+ assert.ok(text.includes(`user_pref("test", 1);`)); // custom preference.
+ });
+ });
+});