summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/debugInfo.spec.ts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /remote/test/puppeteer/test/src/debugInfo.spec.ts
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/test/puppeteer/test/src/debugInfo.spec.ts')
-rw-r--r--remote/test/puppeteer/test/src/debugInfo.spec.ts12
1 files changed, 12 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/src/debugInfo.spec.ts b/remote/test/puppeteer/test/src/debugInfo.spec.ts
index 079107cab7..4f79231667 100644
--- a/remote/test/puppeteer/test/src/debugInfo.spec.ts
+++ b/remote/test/puppeteer/test/src/debugInfo.spec.ts
@@ -15,6 +15,18 @@ describe('DebugInfo', function () {
it('should work', async () => {
const {page, browser} = await getTestState();
+ for (let i = 0; i < 5; i++) {
+ if (!browser.debugInfo.pendingProtocolErrors.length) {
+ break;
+ }
+ await new Promise(resolve => {
+ return setTimeout(resolve, 200);
+ });
+ }
+
+ // Insure that the previous test are flushed
+ expect(browser.debugInfo.pendingProtocolErrors).toHaveLength(0);
+
const promise = page.evaluate(() => {
return new Promise(resolve => {
// @ts-expect-error another context