summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/device-request-prompt.spec.ts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /remote/test/puppeteer/test/src/device-request-prompt.spec.ts
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/test/puppeteer/test/src/device-request-prompt.spec.ts')
-rw-r--r--remote/test/puppeteer/test/src/device-request-prompt.spec.ts53
1 files changed, 53 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/src/device-request-prompt.spec.ts b/remote/test/puppeteer/test/src/device-request-prompt.spec.ts
new file mode 100644
index 0000000000..e6e2cdd65e
--- /dev/null
+++ b/remote/test/puppeteer/test/src/device-request-prompt.spec.ts
@@ -0,0 +1,53 @@
+/**
+ * @license
+ * Copyright 2023 Google Inc.
+ * SPDX-License-Identifier: Apache-2.0
+ */
+import expect from 'expect';
+import {TimeoutError} from 'puppeteer';
+
+import {launch} from './mocha-utils.js';
+
+describe('device request prompt', function () {
+ let state: Awaited<ReturnType<typeof launch>>;
+
+ before(async () => {
+ state = await launch(
+ {
+ args: ['--enable-features=WebBluetoothNewPermissionsBackend'],
+ ignoreHTTPSErrors: true,
+ },
+ {
+ after: 'all',
+ }
+ );
+ });
+
+ after(async () => {
+ await state.close();
+ });
+
+ beforeEach(async () => {
+ state.context = await state.browser.createIncognitoBrowserContext();
+ state.page = await state.context.newPage();
+ });
+
+ afterEach(async () => {
+ await state.context.close();
+ });
+
+ // Bug: #11072
+ it('does not crash', async function () {
+ this.timeout(1_000);
+
+ const {page, httpsServer} = state;
+
+ await page.goto(httpsServer.EMPTY_PAGE);
+
+ await expect(
+ page.waitForDevicePrompt({
+ timeout: 10,
+ })
+ ).rejects.toThrow(TimeoutError);
+ });
+});