summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/fixtures.spec.ts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /remote/test/puppeteer/test/src/fixtures.spec.ts
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/test/puppeteer/test/src/fixtures.spec.ts')
-rw-r--r--remote/test/puppeteer/test/src/fixtures.spec.ts11
1 files changed, 8 insertions, 3 deletions
diff --git a/remote/test/puppeteer/test/src/fixtures.spec.ts b/remote/test/puppeteer/test/src/fixtures.spec.ts
index ca11e94cac..e7a2e1ac9b 100644
--- a/remote/test/puppeteer/test/src/fixtures.spec.ts
+++ b/remote/test/puppeteer/test/src/fixtures.spec.ts
@@ -18,7 +18,7 @@ describe('Fixtures', function () {
it('dumpio option should work with pipe option', async () => {
const {defaultBrowserOptions, puppeteerPath, headless} =
await getTestState();
- if (headless !== 'true') {
+ if (headless !== 'shell') {
// This test only works in the old headless mode.
return;
}
@@ -42,7 +42,8 @@ describe('Fixtures', function () {
expect(dumpioData).toContain('message from dumpio');
});
it('should dump browser process stderr', async () => {
- const {defaultBrowserOptions, puppeteerPath} = await getTestState();
+ const {defaultBrowserOptions, isFirefox, puppeteerPath} =
+ await getTestState();
let dumpioData = '';
const options = Object.assign({}, defaultBrowserOptions, {dumpio: true});
@@ -57,7 +58,11 @@ describe('Fixtures', function () {
await new Promise(resolve => {
return res.on('close', resolve);
});
- expect(dumpioData).toContain('DevTools listening on ws://');
+ if (isFirefox && defaultBrowserOptions.protocol === 'webDriverBiDi') {
+ expect(dumpioData).toContain('WebDriver BiDi listening on ws://');
+ } else {
+ expect(dumpioData).toContain('DevTools listening on ws://');
+ }
});
it('should close the browser when the node process closes', async () => {
const {defaultBrowserOptions, puppeteerPath, puppeteer} =