summaryrefslogtreecommitdiffstats
path: root/security/nss/pkg/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /security/nss/pkg/Makefile
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'security/nss/pkg/Makefile')
-rw-r--r--security/nss/pkg/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/nss/pkg/Makefile b/security/nss/pkg/Makefile
new file mode 100644
index 0000000000..13c0910d36
--- /dev/null
+++ b/security/nss/pkg/Makefile
@@ -0,0 +1,27 @@
+#! gmake
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+CORE_DEPTH = ../..
+DEPTH = ../..
+
+include $(CORE_DEPTH)/coreconf/config.mk
+
+publish:
+ifeq ($(OS_TARGET),Linux)
+ rm -rf $(OBJDIR)
+ cp -r linux $(OBJDIR)
+ $(MAKE) -C $(OBJDIR) publish
+endif
+ifeq ($(OS_TARGET),SunOS)
+ rm -rf $(OBJDIR)
+ cp -r solaris $(OBJDIR)
+ $(MAKE) -C $(OBJDIR) publish
+endif
+
+clean::
+ rm -rf $(OBJDIR)
+
+include $(CORE_DEPTH)/coreconf/rules.mk