summaryrefslogtreecommitdiffstats
path: root/taskcluster/ci/packages
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /taskcluster/ci/packages
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'taskcluster/ci/packages')
-rw-r--r--taskcluster/ci/packages/debian.yml126
-rw-r--r--taskcluster/ci/packages/kind.yml25
-rw-r--r--taskcluster/ci/packages/ubuntu.yml156
3 files changed, 307 insertions, 0 deletions
diff --git a/taskcluster/ci/packages/debian.yml b/taskcluster/ci/packages/debian.yml
new file mode 100644
index 0000000000..0a87ef6782
--- /dev/null
+++ b/taskcluster/ci/packages/debian.yml
@@ -0,0 +1,126 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+---
+job-defaults:
+ run:
+ using: debian-package
+ dist: jessie
+
+deb12-mercurial:
+ description: "Modern Mercurial for Debian bookworm"
+ treeherder:
+ symbol: Deb12(hg)
+ run:
+ using: debian-package
+ dist: bookworm
+ tarball:
+ url: https://www.mercurial-scm.org/release/mercurial-6.4.3.tar.gz
+ sha256: a77fb62d325934a83a00b2fc6db109f44c67b86768fc40490366f513640c7f64
+ pre-build-command: >-
+ cp -r contrib/packaging/debian debian &&
+ sed -i -e "s/__VERSION__/$(awk -F\" '$2 {print $2}' mercurial/__version__.py)-1.deb12moz1/" \
+ -e "s/__DATE__/$(date --rfc-2822)/" \
+ -e "s/__CODENAME__/bookworm/" debian/changelog
+
+deb12-valgrind:
+ description: "Valgrind for Debian bookworm"
+ treeherder:
+ symbol: Deb12(valgrind)
+ run:
+ dist: bookworm
+ dsc:
+ url: http://snapshot.debian.org/archive/debian/20230111T213757Z/pool/main/v/valgrind/valgrind_3.20.0-1.dsc
+ sha256: e32d373bf2d4f0bd0e9673c711d0e4a8eed43c22ca81714ae3e2d85b2f315493
+
+deb12-python-zstandard:
+ description: "python-zstandard for Debian bookworm"
+ treeherder:
+ symbol: Deb12(python-zstandard)
+ run:
+ using: debian-package
+ dist: bookworm
+ tarball:
+ url: https://github.com/indygreg/python-zstandard/releases/download/0.22.0/zstandard-0.22.0.tar.gz
+ sha256: 8226a33c542bcb54cd6bd0a366067b610b41713b64c9abec1bc4533d69f51e70
+ pre-build-command: debchange -v 0.22.0-1.deb12moz --distribution testing "Mozilla backport for bookworm"
+ name: python-zstandard
+
+deb8-gcc-8:
+ description: "gcc 8 for Debian jessie"
+ treeherder:
+ symbol: Deb8(gcc-8)
+ worker:
+ max-run-time: 3600
+ env:
+ DEB_BUILD_OPTIONS: nocheck
+ WITH_BOOTSTRAP: 'off'
+ WITHOUT_LANG: ada brig cilkrts fortran d go objc obj-c++ asan lsan tsan ubsan jit nvptx
+ run:
+ using: debian-package
+ dist: jessie
+ dsc:
+ url: http://snapshot.debian.org/archive/debian/20210202T150504Z/pool/main/g/gcc-8/gcc-8_8.4.0-7.dsc
+ sha256: b93f13bc67f5a8f16e837fbb543d00d3475d5c95777a1b0b5a448fa2310a98c5
+ # autoconf2.64 and quilt necessary to run the `debian/rules control` command to
+ # generate an updated debian/control.
+ # uncommenting `with_common_libs` makes the packaging create the libstdc++6 package.
+ # `libstdcxx_abi = new` overrides the default that disables the new ABI on jessie
+ # `BINUTILSBDV=2.25-3~` and `ISL_BUILD_DEP=libisl-dev,` override wrong versions
+ # in build dependencies for jessie.
+ # `OFFLOAD_BUILD_DEP=` overrides the dependency on nvptx, which is not available
+ # in jessie.
+ # `NT=` overrides the use of `:native` which is not supported by dpkg on jessie.
+ pre-build-command: >-
+ apt install autoconf2.64 quilt &&
+ sed -i 's/#with_common_libs/with_common_libs/' debian/rules.defs &&
+ echo libstdcxx_abi = new >> debian/rules.defs &&
+ echo BINUTILSBDV=2.25-3~ >> debian/rules.conf &&
+ echo ISL_BUILD_DEP=libisl-dev, >> debian/rules.conf &&
+ echo OFFLOAD_BUILD_DEP= >> debian/rules.conf &&
+ debian/rules control NT=
+
+deb8-32-gcc-8:
+ description: "gcc 8 for Debian jessie"
+ treeherder:
+ symbol: Deb8-32(gcc-8)
+ worker:
+ max-run-time: 3600
+ env:
+ DEB_BUILD_OPTIONS: nocheck
+ WITH_BOOTSTRAP: 'off'
+ WITHOUT_LANG: ada biarch brig cilkrts fortran d go objc obj-c++ asan lsan tsan ubsan jit nvptx
+ run:
+ using: debian-package
+ dist: jessie
+ dsc:
+ url: http://snapshot.debian.org/archive/debian/20210202T150504Z/pool/main/g/gcc-8/gcc-8_8.4.0-7.dsc
+ sha256: b93f13bc67f5a8f16e837fbb543d00d3475d5c95777a1b0b5a448fa2310a98c5
+ pre-build-command: >-
+ apt install autoconf2.64 quilt &&
+ sed -i 's/#with_common_libs/with_common_libs/' debian/rules.defs &&
+ echo libstdcxx_abi = new >> debian/rules.defs &&
+ echo GCC_MULTILIB_BUILD_DEP='$(DPKG_BUILD_DEP)' >> debian/rules.conf &&
+ echo BINUTILSBDV=2.25-3~ >> debian/rules.conf &&
+ echo ISL_BUILD_DEP=libisl-dev, >> debian/rules.conf &&
+ echo OFFLOAD_BUILD_DEP= >> debian/rules.conf &&
+ debian/rules control NT=
+ arch: i386
+
+deb8-gtk3:
+ description: "X11-only gtk+3 for Debian jessie"
+ treeherder:
+ symbol: Deb8(gtk)
+ worker:
+ max-run-time: 3600
+ env:
+ DEB_BUILD_OPTIONS: nocheck
+ run:
+ dist: jessie
+ dsc:
+ url: http://snapshot.debian.org/archive/debian/20150819T212910Z/pool/main/g/gtk+3.0/gtk+3.0_3.14.5-1+deb8u1.dsc
+ sha256: b1808b03317b171c813e31185a4520df4dbde54580842a72a4c44540cd6bde17
+ pre-build-command: >-
+ sed -i /linux-any/d debian/control* debian/libgtk-3-0.symbols &&
+ sed -i s/--enable-wayland-backend/--disable-wayland-backend/ debian/rules &&
+ debchange -v 3.14.5-1.deb8moz --distribution jessie-backports "Mozilla rebuild without wayland support"
diff --git a/taskcluster/ci/packages/kind.yml b/taskcluster/ci/packages/kind.yml
new file mode 100644
index 0000000000..5b21346de8
--- /dev/null
+++ b/taskcluster/ci/packages/kind.yml
@@ -0,0 +1,25 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+---
+loader: gecko_taskgraph.loader.transform:loader
+
+transforms:
+ - gecko_taskgraph.transforms.try_job:transforms
+ - gecko_taskgraph.transforms.job:transforms
+ - gecko_taskgraph.transforms.cached_tasks:transforms
+ - gecko_taskgraph.transforms.task:transforms
+
+job-defaults:
+ treeherder:
+ kind: build
+ platform: packages/opt
+ tier: 1
+ worker-type: b-linux-gcp
+ worker:
+ max-run-time: 1800
+ run-on-projects: []
+
+jobs-from:
+ - debian.yml
+ - ubuntu.yml
diff --git a/taskcluster/ci/packages/ubuntu.yml b/taskcluster/ci/packages/ubuntu.yml
new file mode 100644
index 0000000000..d9bbd5f2ad
--- /dev/null
+++ b/taskcluster/ci/packages/ubuntu.yml
@@ -0,0 +1,156 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+---
+job-defaults:
+ run:
+ using: ubuntu-package
+ dist: bionic
+
+ub18-libc6:
+ description: "Older version of glibc in Ubuntu 18.04 that doesn't cause bug 1678451"
+ treeherder:
+ symbol: Ub18(libc6)
+ run:
+ dsc:
+ url: https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/glibc/2.27-3ubuntu1.2/glibc_2.27-3ubuntu1.2.dsc
+ sha256: 2ac325cce2251c710dd041f4725925cdbccefba6f6f0f0d95a2a5a09e2050c2e
+ patch: ubuntu-glibc.diff
+
+ub18-32-libc6:
+ description: "Older version of glibc in Ubuntu 18.04 that doesn't cause bug 1678451"
+ treeherder:
+ symbol: Ub18(libc6-32)
+ run:
+ dsc:
+ url: https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/glibc/2.27-3ubuntu1.2/glibc_2.27-3ubuntu1.2.dsc
+ sha256: 2ac325cce2251c710dd041f4725925cdbccefba6f6f0f0d95a2a5a09e2050c2e
+ arch: i386
+ patch: ubuntu-glibc.diff
+
+ub18-python-psutil:
+ description: "python-psutil for Ubuntu bionic"
+ treeherder:
+ symbol: Ub18(python-psutil)
+ run:
+ dsc:
+ url: https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/python-psutil/5.4.2-1ubuntu0.1/python-psutil_5.4.2-1ubuntu0.1.dsc
+ sha256: a0ca4560d25fcfe5b7407d2cb21318f0635f2c3559898efce1679eef35b61f05
+ name: python-psutil
+ pre-build-command: >-
+ apt-get install python3.8-dev python3.8-dbg &&
+ export DEBPYTHON3_SUPPORTED="3.8"
+
+ub18-pygobject:
+ description: "pygobject for Ubuntu bionic"
+ treeherder:
+ symbol: Ub18(pygobject)
+ run:
+ dsc:
+ url: http://archive.ubuntu.com/ubuntu/pool/main/p/pygobject/pygobject_3.26.1-2ubuntu1.dsc
+ sha256: b77f84885d9b6d2c03422ecb3bf69d50dd0607d3456154943671e5a1f87946aa
+ name: pygobject
+ patch: pygobject.diff
+ pre-build-command: >-
+ apt-get install python3.8-dev python3.8-dbg &&
+ export DEBPYTHON3_SUPPORTED="3.6,3.8"
+
+ub18-pyatspi:
+ description: "pyatspi for Ubuntu bionic"
+ treeherder:
+ symbol: Ub18(pyatspi)
+ run:
+ dsc:
+ url: http://archive.ubuntu.com/ubuntu/pool/main/p/pyatspi/pyatspi_2.26.0+dfsg-1.dsc
+ sha256: 83c57052b055c0e2ee8307e3467d069de859db6c362137be01d142e085026826
+ name: pyatspi
+ pre-build-command: >-
+ sed -i s/\\basync\\b/asynchronous/ pyatspi/registry.py &&
+ EDITOR=cat dpkg-source --commit . sync &&
+ apt-get install python3.8-dev python3.8-dbg &&
+ export DEBPYTHON3_SUPPORTED="3.6,3.8"
+
+ub18-python-zstandard:
+ description: "python-zstandard for Ubuntu bionic"
+ treeherder:
+ symbol: Ub18(python-zstandard)
+ run:
+ tarball:
+ url: https://github.com/indygreg/python-zstandard/releases/download/0.19.0/zstandard-0.19.0.tar.gz
+ sha256: 31d12fcd942dd8dbf52ca5f6b1bbe287f44e5d551a081a983ff3ea2082867863
+ name: python-zstandard
+ pre-build-command: >-
+ apt-get install python3.8-dev &&
+ export DEBPYTHON3_SUPPORTED="3.8" &&
+ debchange -v 0.19.0-1.ub18moz --distribution bionic "Mozilla backport for bionic"
+
+ub18-mercurial:
+ description: "Modern Mercurial for Ubuntu bionic"
+ treeherder:
+ symbol: Ub18(hg)
+ run:
+ tarball:
+ url: https://www.mercurial-scm.org/release/mercurial-6.4.3.tar.gz
+ sha256: a77fb62d325934a83a00b2fc6db109f44c67b86768fc40490366f513640c7f64
+ pre-build-command: >-
+ apt-get install python3.8-dev &&
+ export DEB_HG_PYTHON_VERSIONS="3.8" &&
+ export DEBPYTHON3_SUPPORTED="3.8" &&
+ cp -r contrib/packaging/debian debian &&
+ sed -i -e "s/__VERSION__/$(awk -F\" '$2 {print $2}' mercurial/__version__.py)-1.ub18moz1/" \
+ -e "s/__DATE__/$(date --rfc-2822)/" \
+ -e "s/__CODENAME__/bionic/" debian/changelog
+
+ub20-python-zstandard:
+ description: "python-zstandard for Ubuntu focal"
+ treeherder:
+ symbol: Ub20(python-zstandard)
+ run:
+ tarball:
+ url: https://github.com/indygreg/python-zstandard/releases/download/0.22.0/zstandard-0.22.0.tar.gz
+ sha256: 8226a33c542bcb54cd6bd0a366067b610b41713b64c9abec1bc4533d69f51e70
+ name: python-zstandard
+ dist: focal
+ pre-build-command: debchange -v 0.22.0-1.ub20moz --distribution bionic "Mozilla backport for focal"
+
+ub20-mercurial:
+ description: "Modern Mercurial for Ubuntu focal"
+ treeherder:
+ symbol: Ub20(hg)
+ run:
+ tarball:
+ url: https://www.mercurial-scm.org/release/mercurial-6.4.3.tar.gz
+ sha256: a77fb62d325934a83a00b2fc6db109f44c67b86768fc40490366f513640c7f64
+ dist: focal
+ pre-build-command: >-
+ cp -r contrib/packaging/debian debian &&
+ sed -i -e "s/__VERSION__/$(awk -F\" '$2 {print $2}' mercurial/__version__.py)-1.ub20moz1/" \
+ -e "s/__DATE__/$(date --rfc-2822)/" \
+ -e "s/__CODENAME__/focal/" debian/changelog
+
+ub22-python-zstandard:
+ description: "python-zstandard for Ubuntu jammy"
+ treeherder:
+ symbol: Ub22(python-zstandard)
+ run:
+ tarball:
+ url: https://github.com/indygreg/python-zstandard/releases/download/0.22.0/zstandard-0.22.0.tar.gz
+ sha256: 8226a33c542bcb54cd6bd0a366067b610b41713b64c9abec1bc4533d69f51e70
+ name: python-zstandard
+ dist: jammy
+ pre-build-command: debchange -v 0.22.0-1.ub22moz --distribution jammy "Mozilla backport for jammy"
+
+ub22-mercurial:
+ description: "Modern Mercurial for Ubuntu jammy"
+ treeherder:
+ symbol: Ub22(hg)
+ run:
+ tarball:
+ url: https://www.mercurial-scm.org/release/mercurial-6.4.3.tar.gz
+ sha256: a77fb62d325934a83a00b2fc6db109f44c67b86768fc40490366f513640c7f64
+ dist: jammy
+ pre-build-command: >-
+ cp -r contrib/packaging/debian debian &&
+ sed -i -e "s/__VERSION__/$(awk -F\" '$2 {print $2}' mercurial/__version__.py)-1.ub22moz1/" \
+ -e "s/__DATE__/$(date --rfc-2822)/" \
+ -e "s/__CODENAME__/jammy/" debian/changelog