summaryrefslogtreecommitdiffstats
path: root/taskcluster/scripts/misc/wasi-sdk.patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /taskcluster/scripts/misc/wasi-sdk.patch
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'taskcluster/scripts/misc/wasi-sdk.patch')
-rw-r--r--taskcluster/scripts/misc/wasi-sdk.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/taskcluster/scripts/misc/wasi-sdk.patch b/taskcluster/scripts/misc/wasi-sdk.patch
index 9f7b6ad908..b9e26074d1 100644
--- a/taskcluster/scripts/misc/wasi-sdk.patch
+++ b/taskcluster/scripts/misc/wasi-sdk.patch
@@ -1,3 +1,13 @@
+diff --git a/llvm_version_major.sh b/llvm_version_major.sh
+index 2e5d973..93fe9b0 100755
+--- a/llvm_version_major.sh
++++ b/llvm_version_major.sh
+@@ -1,4 +1,4 @@
+ #/bin/bash
+ LLVM_PROJ_DIR=${1:-./src/llvm-project}
+-MAJOR=`grep "set(LLVM_VERSION_MAJOR" $LLVM_PROJ_DIR/llvm/CMakeLists.txt | awk '{print substr($2, 1, length($2) - 1)}'`
++MAJOR=`(grep "set(LLVM_VERSION_MAJOR" $LLVM_PROJ_DIR/llvm/CMakeLists.txt || grep "set(LLVM_VERSION_MAJOR" $LLVM_PROJ_DIR/cmake/Modules/LLVMVersion.cmake) | awk '{print substr($2, 1, length($2) - 1)}'`
+ echo $MAJOR
diff --git a/Makefile b/Makefile
index d2ccff6..95f395b 100644
--- a/Makefile