summaryrefslogtreecommitdiffstats
path: root/testing/mozharness/docs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/mozharness/docs
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/mozharness/docs')
-rw-r--r--testing/mozharness/docs/Makefile177
-rw-r--r--testing/mozharness/docs/android_emulator_build.rst7
-rw-r--r--testing/mozharness/docs/android_emulator_unittest.rst7
-rw-r--r--testing/mozharness/docs/bouncer_submitter.rst8
-rw-r--r--testing/mozharness/docs/conf.py268
-rw-r--r--testing/mozharness/docs/configtest.rst7
-rw-r--r--testing/mozharness/docs/desktop_l10n.rst7
-rw-r--r--testing/mozharness/docs/desktop_unittest.rst7
-rw-r--r--testing/mozharness/docs/fx_desktop_build.rst7
-rw-r--r--testing/mozharness/docs/index.rst23
-rw-r--r--testing/mozharness/docs/marionette.rst7
-rw-r--r--testing/mozharness/docs/mobile_partner_repack.rst7
-rw-r--r--testing/mozharness/docs/modules.rst13
-rw-r--r--testing/mozharness/docs/mozharness.base.rst85
-rw-r--r--testing/mozharness/docs/mozharness.base.vcs.rst37
-rw-r--r--testing/mozharness/docs/mozharness.mozilla.building.rst22
-rw-r--r--testing/mozharness/docs/mozharness.mozilla.l10n.rst30
-rw-r--r--testing/mozharness/docs/mozharness.mozilla.rst63
-rw-r--r--testing/mozharness/docs/mozharness.mozilla.testing.rst46
-rw-r--r--testing/mozharness/docs/mozharness.rst18
-rw-r--r--testing/mozharness/docs/multil10n.rst7
-rw-r--r--testing/mozharness/docs/scripts.rst16
-rw-r--r--testing/mozharness/docs/talos_script.rst7
-rw-r--r--testing/mozharness/docs/web_platform_tests.rst7
24 files changed, 883 insertions, 0 deletions
diff --git a/testing/mozharness/docs/Makefile b/testing/mozharness/docs/Makefile
new file mode 100644
index 0000000000..980ffbd3b7
--- /dev/null
+++ b/testing/mozharness/docs/Makefile
@@ -0,0 +1,177 @@
+# Makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+PAPER =
+BUILDDIR = _build
+
+# User-friendly check for sphinx-build
+ifeq ($(shell which $(SPHINXBUILD) >/dev/null 2>&1; echo $$?), 1)
+$(error The '$(SPHINXBUILD)' command was not found. Make sure you have Sphinx installed, then set the SPHINXBUILD environment variable to point to the full path of the '$(SPHINXBUILD)' executable. Alternatively you can add the directory with the executable to your PATH. If you don't have Sphinx installed, grab it from http://sphinx-doc.org/)
+endif
+
+# Internal variables.
+PAPEROPT_a4 = -D latex_paper_size=a4
+PAPEROPT_letter = -D latex_paper_size=letter
+ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+# the i18n builder cannot share the environment and doctrees with the others
+I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+
+.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest gettext
+
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " html to make standalone HTML files"
+ @echo " dirhtml to make HTML files named index.html in directories"
+ @echo " singlehtml to make a single large HTML file"
+ @echo " pickle to make pickle files"
+ @echo " json to make JSON files"
+ @echo " htmlhelp to make HTML files and a HTML help project"
+ @echo " qthelp to make HTML files and a qthelp project"
+ @echo " devhelp to make HTML files and a Devhelp project"
+ @echo " epub to make an epub"
+ @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " latexpdf to make LaTeX files and run them through pdflatex"
+ @echo " latexpdfja to make LaTeX files and run them through platex/dvipdfmx"
+ @echo " text to make text files"
+ @echo " man to make manual pages"
+ @echo " texinfo to make Texinfo files"
+ @echo " info to make Texinfo files and run them through makeinfo"
+ @echo " gettext to make PO message catalogs"
+ @echo " changes to make an overview of all changed/added/deprecated items"
+ @echo " xml to make Docutils-native XML files"
+ @echo " pseudoxml to make pseudoxml-XML files for display purposes"
+ @echo " linkcheck to check all external links for integrity"
+ @echo " doctest to run all doctests embedded in the documentation (if enabled)"
+
+clean:
+ rm -rf $(BUILDDIR)/*
+
+html:
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+
+dirhtml:
+ $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
+
+singlehtml:
+ $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
+ @echo
+ @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
+
+pickle:
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
+ @echo
+ @echo "Build finished; now you can process the pickle files."
+
+json:
+ $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
+ @echo
+ @echo "Build finished; now you can process the JSON files."
+
+htmlhelp:
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
+ @echo
+ @echo "Build finished; now you can run HTML Help Workshop with the" \
+ ".hhp project file in $(BUILDDIR)/htmlhelp."
+
+qthelp:
+ $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
+ @echo
+ @echo "Build finished; now you can run "qcollectiongenerator" with the" \
+ ".qhcp project file in $(BUILDDIR)/qthelp, like this:"
+ @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/MozHarness.qhcp"
+ @echo "To view the help file:"
+ @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/MozHarness.qhc"
+
+devhelp:
+ $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
+ @echo
+ @echo "Build finished."
+ @echo "To view the help file:"
+ @echo "# mkdir -p $$HOME/.local/share/devhelp/MozHarness"
+ @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/MozHarness"
+ @echo "# devhelp"
+
+epub:
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+latex:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo
+ @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
+ @echo "Run \`make' in that directory to run these through (pdf)latex" \
+ "(use \`make latexpdf' here to do that automatically)."
+
+latexpdf:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through pdflatex..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+latexpdfja:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through platex and dvipdfmx..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf-ja
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+text:
+ $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
+ @echo
+ @echo "Build finished. The text files are in $(BUILDDIR)/text."
+
+man:
+ $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
+ @echo
+ @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
+
+texinfo:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo
+ @echo "Build finished. The Texinfo files are in $(BUILDDIR)/texinfo."
+ @echo "Run \`make' in that directory to run these through makeinfo" \
+ "(use \`make info' here to do that automatically)."
+
+info:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo "Running Texinfo files through makeinfo..."
+ make -C $(BUILDDIR)/texinfo info
+ @echo "makeinfo finished; the Info files are in $(BUILDDIR)/texinfo."
+
+gettext:
+ $(SPHINXBUILD) -b gettext $(I18NSPHINXOPTS) $(BUILDDIR)/locale
+ @echo
+ @echo "Build finished. The message catalogs are in $(BUILDDIR)/locale."
+
+changes:
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
+ @echo
+ @echo "The overview file is in $(BUILDDIR)/changes."
+
+linkcheck:
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
+ @echo
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
+doctest:
+ $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
+ @echo "Testing of doctests in the sources finished, look at the " \
+ "results in $(BUILDDIR)/doctest/output.txt."
+
+xml:
+ $(SPHINXBUILD) -b xml $(ALLSPHINXOPTS) $(BUILDDIR)/xml
+ @echo
+ @echo "Build finished. The XML files are in $(BUILDDIR)/xml."
+
+pseudoxml:
+ $(SPHINXBUILD) -b pseudoxml $(ALLSPHINXOPTS) $(BUILDDIR)/pseudoxml
+ @echo
+ @echo "Build finished. The pseudo-XML files are in $(BUILDDIR)/pseudoxml."
diff --git a/testing/mozharness/docs/android_emulator_build.rst b/testing/mozharness/docs/android_emulator_build.rst
new file mode 100644
index 0000000000..4087c64d41
--- /dev/null
+++ b/testing/mozharness/docs/android_emulator_build.rst
@@ -0,0 +1,7 @@
+android_emulator_build module
+=============================
+
+.. automodule:: android_emulator_build
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/android_emulator_unittest.rst b/testing/mozharness/docs/android_emulator_unittest.rst
new file mode 100644
index 0000000000..7a8c42c501
--- /dev/null
+++ b/testing/mozharness/docs/android_emulator_unittest.rst
@@ -0,0 +1,7 @@
+android_emulator_unittest module
+================================
+
+.. automodule:: android_emulator_unittest
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/bouncer_submitter.rst b/testing/mozharness/docs/bouncer_submitter.rst
new file mode 100644
index 0000000000..5b71caca7a
--- /dev/null
+++ b/testing/mozharness/docs/bouncer_submitter.rst
@@ -0,0 +1,8 @@
+bouncer_submitter module
+========================
+
+.. automodule:: bouncer_submitter
+ :members:
+ :undoc-members:
+ :private-members:
+ :special-members:
diff --git a/testing/mozharness/docs/conf.py b/testing/mozharness/docs/conf.py
new file mode 100644
index 0000000000..1fb8e80882
--- /dev/null
+++ b/testing/mozharness/docs/conf.py
@@ -0,0 +1,268 @@
+# -*- coding: utf-8 -*-
+#
+# Moz Harness documentation build configuration file, created by
+# sphinx-quickstart on Mon Apr 14 17:35:24 2014.
+#
+# This file is execfile()d with the current directory set to its
+# containing dir.
+#
+# Note that not all possible configuration values are present in this
+# autogenerated file.
+#
+# All configuration values have a default; values that are commented out
+# serve to show the default.
+
+import sys
+import os
+
+# If extensions (or modules to document with autodoc) are in another directory,
+# add these directories to sys.path here. If the directory is relative to the
+# documentation root, use os.path.abspath to make it absolute, like shown here.
+# sys.path.insert(0, os.path.abspath('.'))
+sys.path.insert(0, os.path.abspath("../scripts"))
+sys.path.insert(0, os.path.abspath("../mozharness"))
+
+# -- General configuration ------------------------------------------------
+
+# If your documentation needs a minimal Sphinx version, state it here.
+# needs_sphinx = '1.0'
+
+# Add any Sphinx extension module names here, as strings. They can be
+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
+# ones.
+extensions = [
+ "sphinx.ext.autodoc",
+ "sphinx.ext.intersphinx",
+ "sphinx.ext.viewcode",
+]
+
+# Add any paths that contain templates here, relative to this directory.
+templates_path = ["_templates"]
+
+# The suffix of source filenames.
+source_suffix = ".rst"
+
+# The encoding of source files.
+# source_encoding = 'utf-8-sig'
+
+# The master toctree document.
+master_doc = "index"
+
+# General information about the project.
+project = "Mozharness"
+copyright = "2019, mozilla"
+
+# The version info for the project you're documenting, acts as replacement for
+# |version| and |release|, also used in various other places throughout the
+# built documents.
+#
+# The short X.Y version.
+version = "0.1"
+# The full version, including alpha/beta/rc tags.
+release = "0.1"
+
+# The language for content autogenerated by Sphinx. Refer to documentation
+# for a list of supported languages.
+# language = None
+
+# There are two options for replacing |today|: either, you set today to some
+# non-false value, then it is used:
+# today = ''
+# Else, today_fmt is used as the format for a strftime call.
+# today_fmt = '%B %d, %Y'
+
+# List of patterns, relative to source directory, that match files and
+# directories to ignore when looking for source files.
+exclude_patterns = ["_build"]
+
+# The reST default role (used for this markup: `text`) to use for all
+# documents.
+# default_role = None
+
+# If true, '()' will be appended to :func: etc. cross-reference text.
+# add_function_parentheses = True
+
+# If true, the current module name will be prepended to all description
+# unit titles (such as .. function::).
+# add_module_names = True
+
+# If true, sectionauthor and moduleauthor directives will be shown in the
+# output. They are ignored by default.
+# show_authors = False
+
+# The name of the Pygments (syntax highlighting) style to use.
+pygments_style = "sphinx"
+
+# A list of ignored prefixes for module index sorting.
+# modindex_common_prefix = []
+
+# If true, keep warnings as "system message" paragraphs in the built documents.
+# keep_warnings = False
+
+
+# -- Options for HTML output ----------------------------------------------
+
+# The theme to use for HTML and HTML Help pages. See the documentation for
+# a list of builtin themes.
+html_theme = "default"
+
+# Theme options are theme-specific and customize the look and feel of a theme
+# further. For a list of options available for each theme, see the
+# documentation.
+# html_theme_options = {}
+
+# Add any paths that contain custom themes here, relative to this directory.
+# html_theme_path = []
+
+# The name for this set of Sphinx documents. If None, it defaults to
+# "<project> v<release> documentation".
+# html_title = None
+
+# A shorter title for the navigation bar. Default is the same as html_title.
+# html_short_title = None
+
+# The name of an image file (relative to this directory) to place at the top
+# of the sidebar.
+# html_logo = None
+
+# The name of an image file (within the static path) to use as favicon of the
+# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
+# pixels large.
+# html_favicon = None
+
+# Add any paths that contain custom static files (such as style sheets) here,
+# relative to this directory. They are copied after the builtin static files,
+# so a file named "default.css" will overwrite the builtin "default.css".
+html_static_path = ["_static"]
+
+# Add any extra paths that contain custom files (such as robots.txt or
+# .htaccess) here, relative to this directory. These files are copied
+# directly to the root of the documentation.
+# html_extra_path = []
+
+# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
+# using the given strftime format.
+# html_last_updated_fmt = '%b %d, %Y'
+
+# If true, SmartyPants will be used to convert quotes and dashes to
+# typographically correct entities.
+# html_use_smartypants = True
+
+# Custom sidebar templates, maps document names to template names.
+# html_sidebars = {}
+
+# Additional templates that should be rendered to pages, maps page names to
+# template names.
+# html_additional_pages = {}
+
+# If false, no module index is generated.
+# html_domain_indices = True
+
+# If false, no index is generated.
+# html_use_index = True
+
+# If true, the index is split into individual pages for each letter.
+# html_split_index = False
+
+# If true, links to the reST sources are added to the pages.
+# html_show_sourcelink = True
+
+# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
+# html_show_sphinx = True
+
+# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
+html_show_copyright = False
+
+# If true, an OpenSearch description file will be output, and all pages will
+# contain a <link> tag referring to it. The value of this option must be the
+# base URL from which the finished HTML is served.
+# html_use_opensearch = ''
+
+# This is the file name suffix for HTML files (e.g. ".xhtml").
+# html_file_suffix = None
+
+# Output file base name for HTML help builder.
+htmlhelp_basename = "MozHarnessdoc"
+
+
+# -- Options for LaTeX output ---------------------------------------------
+
+latex_elements = {
+ # The paper size ('letterpaper' or 'a4paper').
+ #'papersize': 'letterpaper',
+ # The font size ('10pt', '11pt' or '12pt').
+ #'pointsize': '10pt',
+ # Additional stuff for the LaTeX preamble.
+ #'preamble': '',
+}
+
+# Grouping the document tree into LaTeX files. List of tuples
+# (source start file, target name, title,
+# author, documentclass [howto, manual, or own class]).
+latex_documents = [
+ ("index", "MozHarness.tex", "Mozharness Documentation", "mozilla", "manual"),
+]
+
+# The name of an image file (relative to this directory) to place at the top of
+# the title page.
+# latex_logo = None
+
+# For "manual" documents, if this is true, then toplevel headings are parts,
+# not chapters.
+# latex_use_parts = False
+
+# If true, show page references after internal links.
+# latex_show_pagerefs = False
+
+# If true, show URL addresses after external links.
+# latex_show_urls = False
+
+# Documents to append as an appendix to all manuals.
+# latex_appendices = []
+
+# If false, no module index is generated.
+# latex_domain_indices = True
+
+
+# -- Options for manual page output ---------------------------------------
+
+# One entry per manual page. List of tuples
+# (source start file, name, description, authors, manual section).
+man_pages = [("index", "mozharness", "Mozharness Documentation", ["mozilla"], 1)]
+
+# If true, show URL addresses after external links.
+# man_show_urls = False
+
+
+# -- Options for Texinfo output -------------------------------------------
+
+# Grouping the document tree into Texinfo files. List of tuples
+# (source start file, target name, title, author,
+# dir menu entry, description, category)
+texinfo_documents = [
+ (
+ "index",
+ "Mozharness",
+ "Mozharness Documentation",
+ "mozilla",
+ "Mozharness",
+ "One line description of project.",
+ "Miscellaneous",
+ ),
+]
+
+# Documents to append as an appendix to all manuals.
+# texinfo_appendices = []
+
+# If false, no module index is generated.
+# texinfo_domain_indices = True
+
+# How to display URL addresses: 'footnote', 'no', or 'inline'.
+# texinfo_show_urls = 'footnote'
+
+# If true, do not generate a @detailmenu in the "Top" node's menu.
+# texinfo_no_detailmenu = False
+
+
+# Example configuration for intersphinx: refer to the Python standard library.
+intersphinx_mapping = {"http://docs.python.org/": None}
diff --git a/testing/mozharness/docs/configtest.rst b/testing/mozharness/docs/configtest.rst
new file mode 100644
index 0000000000..10e4a56c96
--- /dev/null
+++ b/testing/mozharness/docs/configtest.rst
@@ -0,0 +1,7 @@
+configtest module
+=================
+
+.. automodule:: configtest
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/desktop_l10n.rst b/testing/mozharness/docs/desktop_l10n.rst
new file mode 100644
index 0000000000..b94dadedcf
--- /dev/null
+++ b/testing/mozharness/docs/desktop_l10n.rst
@@ -0,0 +1,7 @@
+desktop_l10n module
+===================
+
+.. automodule:: desktop_l10n
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/desktop_unittest.rst b/testing/mozharness/docs/desktop_unittest.rst
new file mode 100644
index 0000000000..f70e8d8d9e
--- /dev/null
+++ b/testing/mozharness/docs/desktop_unittest.rst
@@ -0,0 +1,7 @@
+desktop_unittest module
+=======================
+
+.. automodule:: desktop_unittest
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/fx_desktop_build.rst b/testing/mozharness/docs/fx_desktop_build.rst
new file mode 100644
index 0000000000..b5d6ac21c2
--- /dev/null
+++ b/testing/mozharness/docs/fx_desktop_build.rst
@@ -0,0 +1,7 @@
+fx_desktop_build module
+=======================
+
+.. automodule:: fx_desktop_build
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/index.rst b/testing/mozharness/docs/index.rst
new file mode 100644
index 0000000000..04b3a2e382
--- /dev/null
+++ b/testing/mozharness/docs/index.rst
@@ -0,0 +1,23 @@
+.. Moz Harness documentation master file, created by
+ sphinx-quickstart on Mon Apr 14 17:35:24 2014.
+ You can adapt this file completely to your liking, but it should at least
+ contain the root `toctree` directive.
+
+Welcome to Moz Harness's documentation!
+=======================================
+
+Contents:
+
+.. toctree::
+ :maxdepth: 2
+
+ modules.rst
+ scripts.rst
+
+
+Indices and tables
+==================
+
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`
diff --git a/testing/mozharness/docs/marionette.rst b/testing/mozharness/docs/marionette.rst
new file mode 100644
index 0000000000..28763406be
--- /dev/null
+++ b/testing/mozharness/docs/marionette.rst
@@ -0,0 +1,7 @@
+marionette module
+=================
+
+.. automodule:: marionette
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/mobile_partner_repack.rst b/testing/mozharness/docs/mobile_partner_repack.rst
new file mode 100644
index 0000000000..f8be0bef86
--- /dev/null
+++ b/testing/mozharness/docs/mobile_partner_repack.rst
@@ -0,0 +1,7 @@
+mobile_partner_repack module
+============================
+
+.. automodule:: mobile_partner_repack
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/modules.rst b/testing/mozharness/docs/modules.rst
new file mode 100644
index 0000000000..73652563b6
--- /dev/null
+++ b/testing/mozharness/docs/modules.rst
@@ -0,0 +1,13 @@
+mozharness
+==========
+
+.. toctree::
+ :maxdepth: 4
+
+ mozharness
+ mozharness.base.rst
+ mozharness.base.vcs.rst
+ mozharness.mozilla.building.rst
+ mozharness.mozilla.l10n.rst
+ mozharness.mozilla.rst
+ mozharness.mozilla.testing.rst
diff --git a/testing/mozharness/docs/mozharness.base.rst b/testing/mozharness/docs/mozharness.base.rst
new file mode 100644
index 0000000000..dc46a45ba8
--- /dev/null
+++ b/testing/mozharness/docs/mozharness.base.rst
@@ -0,0 +1,85 @@
+mozharness.base package
+=======================
+
+Subpackages
+-----------
+
+.. toctree::
+
+ mozharness.base.vcs
+
+Submodules
+----------
+
+mozharness.base.config module
+-----------------------------
+
+.. automodule:: mozharness.base.config
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.errors module
+-----------------------------
+
+.. automodule:: mozharness.base.errors
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.log module
+--------------------------
+
+.. automodule:: mozharness.base.log
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.mar module
+--------------------------
+
+.. automodule:: mozharness.base.mar
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.parallel module
+-------------------------------
+
+.. automodule:: mozharness.base.parallel
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.python module
+-----------------------------
+
+.. automodule:: mozharness.base.python
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.script module
+-----------------------------
+
+.. automodule:: mozharness.base.script
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.transfer module
+-------------------------------
+
+.. automodule:: mozharness.base.transfer
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Module contents
+---------------
+
+.. automodule:: mozharness.base
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/mozharness.base.vcs.rst b/testing/mozharness/docs/mozharness.base.vcs.rst
new file mode 100644
index 0000000000..3418463593
--- /dev/null
+++ b/testing/mozharness/docs/mozharness.base.vcs.rst
@@ -0,0 +1,37 @@
+mozharness.base.vcs package
+===========================
+
+Submodules
+----------
+
+mozharness.base.vcs.gittool module
+----------------------------------
+
+.. automodule:: mozharness.base.vcs.gittool
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.vcs.mercurial module
+------------------------------------
+
+.. automodule:: mozharness.base.vcs.mercurial
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.base.vcs.vcsbase module
+----------------------------------
+
+.. automodule:: mozharness.base.vcs.vcsbase
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+Module contents
+---------------
+
+.. automodule:: mozharness.base.vcs
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/mozharness.mozilla.building.rst b/testing/mozharness/docs/mozharness.mozilla.building.rst
new file mode 100644
index 0000000000..b8b6106c24
--- /dev/null
+++ b/testing/mozharness/docs/mozharness.mozilla.building.rst
@@ -0,0 +1,22 @@
+mozharness.mozilla.building package
+===================================
+
+Submodules
+----------
+
+mozharness.mozilla.building.buildbase module
+--------------------------------------------
+
+.. automodule:: mozharness.mozilla.building.buildbase
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Module contents
+---------------
+
+.. automodule:: mozharness.mozilla.building
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/mozharness.mozilla.l10n.rst b/testing/mozharness/docs/mozharness.mozilla.l10n.rst
new file mode 100644
index 0000000000..6951ec1a76
--- /dev/null
+++ b/testing/mozharness/docs/mozharness.mozilla.l10n.rst
@@ -0,0 +1,30 @@
+mozharness.mozilla.l10n package
+===============================
+
+Submodules
+----------
+
+mozharness.mozilla.l10n.locales module
+--------------------------------------
+
+.. automodule:: mozharness.mozilla.l10n.locales
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.mozilla.l10n.multi_locale_build module
+-------------------------------------------------
+
+.. automodule:: mozharness.mozilla.l10n.multi_locale_build
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Module contents
+---------------
+
+.. automodule:: mozharness.mozilla.l10n
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/mozharness.mozilla.rst b/testing/mozharness/docs/mozharness.mozilla.rst
new file mode 100644
index 0000000000..016761320e
--- /dev/null
+++ b/testing/mozharness/docs/mozharness.mozilla.rst
@@ -0,0 +1,63 @@
+mozharness.mozilla package
+==========================
+
+Subpackages
+-----------
+
+.. toctree::
+
+ mozharness.mozilla.building
+ mozharness.mozilla.l10n
+ mozharness.mozilla.testing
+
+Submodules
+----------
+
+mozharness.mozilla.blob_upload module
+-------------------------------------
+
+.. automodule:: mozharness.mozilla.blob_upload
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.mozilla.automation module
+----------------------------------
+
+.. automodule:: mozharness.mozilla.automation
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.mozilla.mozbase module
+---------------------------------
+
+.. automodule:: mozharness.mozilla.mozbase
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.mozilla.purge module
+-------------------------------
+
+.. automodule:: mozharness.mozilla.purge
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.mozilla.tooltool module
+----------------------------------
+
+.. automodule:: mozharness.mozilla.tooltool
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Module contents
+---------------
+
+.. automodule:: mozharness.mozilla
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/mozharness.mozilla.testing.rst b/testing/mozharness/docs/mozharness.mozilla.testing.rst
new file mode 100644
index 0000000000..388ee9925b
--- /dev/null
+++ b/testing/mozharness/docs/mozharness.mozilla.testing.rst
@@ -0,0 +1,46 @@
+mozharness.mozilla.testing package
+==================================
+
+Submodules
+----------
+
+mozharness.mozilla.testing.errors module
+----------------------------------------
+
+.. automodule:: mozharness.mozilla.testing.errors
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.mozilla.testing.talos module
+---------------------------------------
+
+.. automodule:: mozharness.mozilla.testing.talos
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.mozilla.testing.testbase module
+------------------------------------------
+
+.. automodule:: mozharness.mozilla.testing.testbase
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+mozharness.mozilla.testing.unittest module
+------------------------------------------
+
+.. automodule:: mozharness.mozilla.testing.unittest
+ :members:
+ :undoc-members:
+ :show-inheritance:
+
+
+Module contents
+---------------
+
+.. automodule:: mozharness.mozilla.testing
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/mozharness.rst b/testing/mozharness/docs/mozharness.rst
new file mode 100644
index 0000000000..f14e6b91e4
--- /dev/null
+++ b/testing/mozharness/docs/mozharness.rst
@@ -0,0 +1,18 @@
+mozharness package
+==================
+
+Subpackages
+-----------
+
+.. toctree::
+
+ mozharness.base
+ mozharness.mozilla
+
+Module contents
+---------------
+
+.. automodule:: mozharness
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/multil10n.rst b/testing/mozharness/docs/multil10n.rst
new file mode 100644
index 0000000000..b14e62b78e
--- /dev/null
+++ b/testing/mozharness/docs/multil10n.rst
@@ -0,0 +1,7 @@
+multil10n module
+================
+
+.. automodule:: multil10n
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/scripts.rst b/testing/mozharness/docs/scripts.rst
new file mode 100644
index 0000000000..972dae5601
--- /dev/null
+++ b/testing/mozharness/docs/scripts.rst
@@ -0,0 +1,16 @@
+scripts
+=======
+
+.. toctree::
+ android_emulator_build.rst
+ android_emulator_unittest.rst
+ bouncer_submitter.rst
+ configtest.rst
+ desktop_l10n.rst
+ desktop_unittest.rst
+ fx_desktop_build.rst
+ marionette.rst
+ mobile_partner_repack.rst
+ multil10n.rst
+ talos_script.rst
+ web_platform_tests.rst
diff --git a/testing/mozharness/docs/talos_script.rst b/testing/mozharness/docs/talos_script.rst
new file mode 100644
index 0000000000..509aac400e
--- /dev/null
+++ b/testing/mozharness/docs/talos_script.rst
@@ -0,0 +1,7 @@
+talos_script module
+===================
+
+.. automodule:: talos_script
+ :members:
+ :undoc-members:
+ :show-inheritance:
diff --git a/testing/mozharness/docs/web_platform_tests.rst b/testing/mozharness/docs/web_platform_tests.rst
new file mode 100644
index 0000000000..6a2887aa8e
--- /dev/null
+++ b/testing/mozharness/docs/web_platform_tests.rst
@@ -0,0 +1,7 @@
+web_platform_tests module
+=========================
+
+.. automodule:: web_platform_tests
+ :members:
+ :undoc-members:
+ :show-inheritance: