summaryrefslogtreecommitdiffstats
path: root/testing/tps/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/tps/setup.py
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/tps/setup.py')
-rw-r--r--testing/tps/setup.py50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/tps/setup.py b/testing/tps/setup.py
new file mode 100644
index 0000000000..0bcf4387f0
--- /dev/null
+++ b/testing/tps/setup.py
@@ -0,0 +1,50 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+
+from setuptools import find_packages, setup
+
+version = "0.6"
+
+deps = [
+ "httplib2 == 0.9.2",
+ "mozfile >= 1.2",
+ "wptserve >= 3.0",
+ "mozinfo >= 1.2",
+ "mozinstall == 2.0.1",
+ "mozprocess == 1.3",
+ "mozprofile ~= 2.1",
+ "mozrunner ~= 8.2",
+ "mozversion == 2.3",
+ "PyYAML >= 4.0",
+]
+
+setup(
+ name="tps",
+ version=version,
+ description="run automated multi-profile sync tests",
+ long_description="""\
+""",
+ classifiers=[
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 2 :: Only",
+ ], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ keywords="",
+ author="Mozilla Automation and Tools team",
+ author_email="tools@lists.mozilla.org",
+ url="https://developer.mozilla.org/en-US/docs/TPS",
+ license="MPL 2.0",
+ packages=find_packages(exclude=["ez_setup", "examples", "tests"]),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=deps,
+ entry_points="""
+ # -*- Entry points: -*-
+ [console_scripts]
+ runtps = tps.cli:main
+ """,
+ data_files=[
+ ("tps", ["config/config.json.in"]),
+ ],
+)