summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/background-fetch/port-blocking.https.window.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/background-fetch/port-blocking.https.window.js
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/background-fetch/port-blocking.https.window.js')
-rw-r--r--testing/web-platform/tests/background-fetch/port-blocking.https.window.js39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/web-platform/tests/background-fetch/port-blocking.https.window.js b/testing/web-platform/tests/background-fetch/port-blocking.https.window.js
new file mode 100644
index 0000000000..358f382b64
--- /dev/null
+++ b/testing/web-platform/tests/background-fetch/port-blocking.https.window.js
@@ -0,0 +1,39 @@
+// META: script=/service-workers/service-worker/resources/test-helpers.sub.js
+// META: script=resources/utils.js
+'use strict';
+
+// Tests that requests to bad ports are blocked.
+// https://fetch.spec.whatwg.org/#port-blocking
+
+// This is not a comprehensive test of blocked ports - it is just intended to
+// check that blocking is enabled.
+
+backgroundFetchTest((t, bgFetch) => {
+ return bgFetch.fetch(uniqueId(), 'https://example.com');
+}, 'fetch to default https port should register ok');
+
+backgroundFetchTest((t, bgFetch) => {
+ return bgFetch.fetch(uniqueId(), 'http://127.0.0.1');
+}, 'fetch to default http port should register ok');
+
+backgroundFetchTest((t, bgFetch) => {
+ return bgFetch.fetch(uniqueId(), 'https://example.com:443');
+}, 'fetch to port 443 should register ok');
+
+backgroundFetchTest((t, bgFetch) => {
+ return bgFetch.fetch(uniqueId(), 'https://example.com:80');
+}, 'fetch to port 80 should register ok, even over https');
+
+backgroundFetchTest((t, bgFetch) => {
+ return bgFetch.fetch(uniqueId(), 'https://example.com:8080');
+}, 'fetch to non-default non-bad port (8080) should register ok');
+
+backgroundFetchTest(async (t, bgFetch) => {
+ const promise = bgFetch.fetch(uniqueId(), 'https://example.com:587').then(fetch => {
+ return fetch.match('https://example.com:587');
+ }).then(record => record.responseReady);
+
+ return promise_rejects_js(
+ t, TypeError,
+ promise);
+}, 'fetch to bad port (SMTP) should reject');