summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/compat/webkit-linear-gradient-line-left.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/compat/webkit-linear-gradient-line-left.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/compat/webkit-linear-gradient-line-left.html')
-rw-r--r--testing/web-platform/tests/compat/webkit-linear-gradient-line-left.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/compat/webkit-linear-gradient-line-left.html b/testing/web-platform/tests/compat/webkit-linear-gradient-line-left.html
new file mode 100644
index 0000000000..22c2e0b04c
--- /dev/null
+++ b/testing/web-platform/tests/compat/webkit-linear-gradient-line-left.html
@@ -0,0 +1,23 @@
+<!doctype html>
+<title>-webkit-linear-gradient(left)</title>
+<link rel="author" title="Xidorn Quan" href="me@upsuper.org">
+<link rel="author" title="Mozilla" href="https://www.mozilla.org">
+<link rel="help" href="https://compat.spec.whatwg.org/#css-gradients-webkit-linear-gradient">
+<meta name="assert" content="'left' in -webkit-linear-gradient is equivalent to 'to right' in modern syntax">
+<link rel="match" href="green-ref.html">
+<meta name="fuzzy" content="maxDifference=0-1; totalPixels=0-4400">
+<style>
+ #outer {
+ width: 100px;
+ height: 100px;
+ overflow: hidden;
+ }
+ #inner {
+ width: 200px;
+ height: 100px;
+ background-image: -webkit-linear-gradient(left, green 50%, red 50%);
+ }
+</style>
+<div id="outer">
+ <div id="inner"></div>
+</div>