summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/cors/basic.htm
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/cors/basic.htm
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/cors/basic.htm')
-rw-r--r--testing/web-platform/tests/cors/basic.htm55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/web-platform/tests/cors/basic.htm b/testing/web-platform/tests/cors/basic.htm
new file mode 100644
index 0000000000..cbdb4ca9aa
--- /dev/null
+++ b/testing/web-platform/tests/cors/basic.htm
@@ -0,0 +1,55 @@
+<!DOCTYPE html>
+<meta charset=utf-8>
+<title>Basic CORS</title>
+<link rel=help href=https://fetch.spec.whatwg.org/>
+<meta name=author title="Odin Hørthe Omdal" href="mailto:odiho@opera.com">
+
+<script src=/resources/testharness.js></script>
+<script src=/resources/testharnessreport.js></script>
+<script src=/common/utils.js></script>
+<script src=support.js?pipe=sub></script>
+<div id=log></div>
+
+<script>
+function cors(desc, scheme, subdomain = "", port = location.port) {
+ const sameorigin = !scheme;
+ const base =
+ sameorigin ? "" : `${scheme}://${subdomain}${location.hostname}:${port}${dirname(location.pathname)}`;
+
+ async_test((t) => {
+ const client = new XMLHttpRequest();
+ client.open("GET", `${base}resources/cors-makeheader.py?get_value=hest_er_best&origin=none&${token()}`);
+ client.send();
+
+ client.onload = t.step_func_done(() => {
+ assert_true(sameorigin, "Cross origin request must be rejected.");
+ assert_true(client.response.includes("hest_er_best"), "Got response");
+ });
+ client.onerror = t.step_func_done(() => {
+ assert_false(sameorigin, "Same origin request must be accepted.");
+ });
+ }, `${desc}, origin: none`);
+
+ async_test((t) => {
+ const client = new XMLHttpRequest();
+ client.open("GET", `${base}resources/cors-makeheader.py?get_value=hest_er_best&${token()}`);
+ client.send();
+
+ client.onload = t.step_func_done(() => {
+ assert_true(client.response.includes("hest_er_best"), "Got response");
+ });
+ client.onerror = t.unreached_func("Should be accepted");
+ }, `${desc}, origin: echo`);
+}
+
+cors("Same domain basic usage");
+cors("Cross domain basic usage", "http", "www1.");
+cors("Same domain different port", "http", undefined, PORT);
+
+cors("Cross domain different port", "http", "www1.", PORT);
+
+cors("Cross domain different protocol", "https", "www1.", PORTS);
+
+cors("Same domain different protocol different port", "https", undefined, PORTS);
+
+</script>