summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-pseudo/backdrop-animate.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/css-pseudo/backdrop-animate.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/css-pseudo/backdrop-animate.html')
-rw-r--r--testing/web-platform/tests/css/css-pseudo/backdrop-animate.html29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-pseudo/backdrop-animate.html b/testing/web-platform/tests/css/css-pseudo/backdrop-animate.html
new file mode 100644
index 0000000000..73bf6bf6f6
--- /dev/null
+++ b/testing/web-platform/tests/css/css-pseudo/backdrop-animate.html
@@ -0,0 +1,29 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>CSS Pseudo-Elements Test: ::backdrop & web animations</title>
+<link rel="help" href="https://fullscreen.spec.whatwg.org/#::backdrop-pseudo-element">
+<link rel="help" href="https://drafts.csswg.org/web-animations-1/">
+<meta name="assert" content="This test checks that ::backdrop can be animated with Web Animations." />
+<div id="log"></div>
+<dialog id="target">Dialog contents</dialog>
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script>
+const target = document.getElementById("target");
+target.showModal();
+
+test(function() {
+ const options = {
+ pseudoElement: "::backdrop",
+ duration: 2,
+ delay: -1,
+ };
+ const cs = getComputedStyle(target, "::backdrop");
+ const anim = target.animate([
+ {backgroundColor: "rgb(0, 100, 200)"},
+ {backgroundColor: "rgb(200, 0, 100)"},
+ ], options);
+ this.add_cleanup(() => anim.cancel());
+ assert_equals(cs.backgroundColor, "rgb(100, 50, 150)", "background-color");
+}, "'backgroundColor' animation");
+</script>