summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-scoping/stylesheet-title-002.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/css-scoping/stylesheet-title-002.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/css-scoping/stylesheet-title-002.html')
-rw-r--r--testing/web-platform/tests/css/css-scoping/stylesheet-title-002.html36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-scoping/stylesheet-title-002.html b/testing/web-platform/tests/css/css-scoping/stylesheet-title-002.html
new file mode 100644
index 0000000000..2843ada3ee
--- /dev/null
+++ b/testing/web-platform/tests/css/css-scoping/stylesheet-title-002.html
@@ -0,0 +1,36 @@
+<!doctype html>
+<meta charset="utf-8">
+<title>CSS Test: title attribute in stylesheets not in the document tree is ignored</title>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="help" href="https://drafts.csswg.org/cssom/#preferred-css-style-sheet-set-name">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/#attr-style-title">
+<link rel="help" href="https://github.com/w3c/webcomponents/issues/535">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<div id="host"></div>
+<script>
+test(function() {
+ host.attachShadow({ mode: "open" }).innerHTML = `
+ <style>
+ div { width: 100px; height: 100px; }
+ </style>
+ <style title="Foo">
+ div { background: purple }
+ </style>
+ <style title="Bar">
+ div { background: green }
+ </style>
+ <div></div>
+ `;
+ assert_equals(host.shadowRoot.styleSheets.length, 3);
+ for (let sheet of host.shadowRoot.styleSheets) {
+ assert_equals(sheet.title, null, "Sheet outside of the document generates no setter");
+ sheet.title = "Foo";
+ assert_equals(sheet.title, null, "Mutation doesn't change the sheet title");
+ }
+ for (let element of host.shadowRoot.querySelectorAll("style")) {
+ element.setAttribute("title", "Foo");
+ assert_equals(element.sheet.title, null, "Attribute mutation doesn't change the sheet title");
+ }
+}, "Title attribute in stylesheets not in the document tree is ignored");
+</script>