summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-tables/dynamic-rowspan-change.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/css-tables/dynamic-rowspan-change.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/css-tables/dynamic-rowspan-change.html')
-rw-r--r--testing/web-platform/tests/css/css-tables/dynamic-rowspan-change.html45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-tables/dynamic-rowspan-change.html b/testing/web-platform/tests/css/css-tables/dynamic-rowspan-change.html
new file mode 100644
index 0000000000..c02f84b4a5
--- /dev/null
+++ b/testing/web-platform/tests/css/css-tables/dynamic-rowspan-change.html
@@ -0,0 +1,45 @@
+<!doctype html>
+<script src='/resources/testharness.js'></script>
+<script src='/resources/testharnessreport.js'></script>
+<script src='/resources/check-layout-th.js'></script>
+<link rel="author" href="mailto:atotic@chromium.org">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/tables.html#the-td-element">
+<meta name="assert" content="Dynamic changes to rowspan/colspan relayout the table" />
+<style>
+ main table {
+ border-spacing:0;
+ }
+ main td {
+ background: green;
+ width:50px;
+ height:50px;
+ padding: 0;
+ }
+</style>
+
+<main>
+ <table data-expected-width="100">
+ <tr>
+ <td id="rowspan_target"></td>
+ </tr>
+ <tr>
+ <td></td>
+ </tr>
+ </table>
+<br>
+ <table data-expected-width="150">
+ <col style="width:50px">
+ <col style="width:50px">
+ <tr>
+ <td id="colspan_target"></td>
+ <td></td>
+ </tr>
+ </table>
+</main>
+
+<script>
+ document.body.offsetTop;
+ document.querySelector("#rowspan_target").setAttribute("rowspan", "2");
+ document.querySelector("#colspan_target").setAttribute("colspan", "2");
+ checkLayout("main table");
+</script>