summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/CSS-namespace-object-class-string.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/cssom/CSS-namespace-object-class-string.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/cssom/CSS-namespace-object-class-string.html')
-rw-r--r--testing/web-platform/tests/css/cssom/CSS-namespace-object-class-string.html47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/CSS-namespace-object-class-string.html b/testing/web-platform/tests/css/cssom/CSS-namespace-object-class-string.html
new file mode 100644
index 0000000000..3145467073
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/CSS-namespace-object-class-string.html
@@ -0,0 +1,47 @@
+<!doctype html>
+<meta charset="utf-8">
+<title>CSSOM - Symbol.toStringTag value of CSS namespace object</title>
+<link rel="help" href="https://webidl.spec.whatwg.org/#es-namespaces">
+<link rel="help" href="https://drafts.csswg.org/cssom/#namespacedef-css">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script>
+"use strict";
+
+test(() => {
+ assert_own_property(CSS, Symbol.toStringTag);
+
+ const propDesc = Object.getOwnPropertyDescriptor(CSS, Symbol.toStringTag);
+ assert_equals(propDesc.value, "CSS", "value");
+ assert_equals(propDesc.writable, false, "writable");
+ assert_equals(propDesc.enumerable, false, "enumerable");
+ assert_equals(propDesc.configurable, true, "configurable");
+}, "@@toStringTag exists on the namespace object with the appropriate descriptor");
+
+test(() => {
+ assert_equals(CSS.toString(), "[object CSS]");
+ assert_equals(Object.prototype.toString.call(CSS), "[object CSS]");
+}, "Object.prototype.toString applied to the namespace object");
+
+test(t => {
+ assert_own_property(CSS, Symbol.toStringTag, "Precondition: @@toStringTag on the namespace object");
+ t.add_cleanup(() => {
+ Object.defineProperty(CSS, Symbol.toStringTag, { value: "CSS" });
+ });
+
+ Object.defineProperty(CSS, Symbol.toStringTag, { value: "Test" });
+ assert_equals(CSS.toString(), "[object Test]");
+ assert_equals(Object.prototype.toString.call(CSS), "[object Test]");
+}, "Object.prototype.toString applied after modifying the namespace object's @@toStringTag");
+
+test(t => {
+ assert_own_property(CSS, Symbol.toStringTag, "Precondition: @@toStringTag on the namespace object");
+ t.add_cleanup(() => {
+ Object.defineProperty(CSS, Symbol.toStringTag, { value: "CSS" });
+ });
+
+ assert_true(delete CSS[Symbol.toStringTag]);
+ assert_equals(CSS.toString(), "[object Object]");
+ assert_equals(Object.prototype.toString.call(CSS), "[object Object]");
+}, "Object.prototype.toString applied after deleting @@toStringTag");
+</script>