summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-003.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-003.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-003.html')
-rw-r--r--testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-003.html31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-003.html b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-003.html
new file mode 100644
index 0000000000..3d391bbaff
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-003.html
@@ -0,0 +1,31 @@
+<!doctype html>
+<title>&lt;link disabled&gt;'s "explicitly enabled" state persists after getting disconnected from the tree</title>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="author" title="Mozilla" href="https://mozilla.org">
+<link rel="help" href="https://html.spec.whatwg.org/#attr-link-disabled">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<link title="alt" rel="alternate stylesheet" disabled href="data:text/css,html { background: green }">
+<script>
+function assert_applies(applies) {
+ (applies ? assert_equals : assert_not_equals)(getComputedStyle(document.documentElement).backgroundColor, "rgb(0, 128, 0)");
+}
+
+const link = document.querySelector("link[disabled]");
+async_test(function(t) {
+ assert_true(link.disabled);
+ link.disabled = false;
+ assert_false(link.disabled);
+ assert_true(!link.hasAttribute("disabled"));
+ link.remove();
+
+ link.onload = t.step_func_done(function() {
+ assert_equals(document.styleSheets.length, 1);
+ let sheet = document.styleSheets[0];
+ assert_equals(sheet.ownerNode, link);
+ assert_applies(true);
+ });
+
+ document.head.appendChild(link);
+}, "HTMLLinkElement.disabled's explicitly enabled state persists when disconnected and connected again");
+</script>