summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-004.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-004.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-004.html')
-rw-r--r--testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-004.html39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-004.html b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-004.html
new file mode 100644
index 0000000000..f163f1d68e
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-004.html
@@ -0,0 +1,39 @@
+<!doctype html>
+<title>&lt;link disabled&gt;'s "explicitly enabled" state doesn't persist for clones</title>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="author" title="Mozilla" href="https://mozilla.org">
+<link rel="help" href="https://html.spec.whatwg.org/#attr-link-disabled">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<link title="alt" rel="alternate stylesheet" disabled href="data:text/css,html { background: green }">
+<script>
+function assert_applies(applies) {
+ (applies ? assert_equals : assert_not_equals)(getComputedStyle(document.documentElement).backgroundColor, "rgb(0, 128, 0)");
+}
+
+const link = document.querySelector("link[disabled]");
+
+async_test(function(t) {
+ link.remove();
+ link.disabled = false; // `link` is explicitly enabled.
+
+ let clonesLoaded = 0;
+
+ for (let shallow of [true, false]) {
+ const clone = link.cloneNode(shallow);
+ clone.onload = t.step_func(function() {
+ assert_false(link.disabled);
+ // Even though it's not disabled, it still doesn't apply, since it's an alternate.
+ assert_applies(false);
+ if (++clonesLoaded == 2) {
+ link.onload = t.step_func_done(function() {
+ assert_false(link.disabled);
+ assert_applies(true); // `link` is still explicitly enabled.
+ });
+ document.head.appendChild(link);
+ }
+ });
+ document.head.appendChild(clone);
+ }
+}, "HTMLLinkElement.disabled's explicitly enabled state doesn't persist on clones");
+</script>