summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-alternate.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-alternate.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-alternate.html')
-rw-r--r--testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-alternate.html14
1 files changed, 14 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-alternate.html b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-alternate.html
new file mode 100644
index 0000000000..f1457c0dcf
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-alternate.html
@@ -0,0 +1,14 @@
+<!DOCTYPE html>
+<html class="reftest-wait">
+<title>CSS Test: alternate stylesheets can be disabled by HTMLLinkElement.disabled if they have the disabled attribute already</title>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="author" title="Mozilla" href="https://mozilla.org">
+<link rel="help" href="https://html.spec.whatwg.org/#attr-link-disabled">
+<link rel="match" href="HTMLLinkElement-disabled-alternate-ref.html">
+<link title="alt" rel="alternate stylesheet" href="data:text/css,html { background: green }" disabled onload="document.documentElement.className = ''">
+<script>
+ onload = function() {
+ const link = document.querySelector("link[rel='alternate stylesheet']");
+ link.disabled = false;
+ }
+</script>