summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/HTMLStyleElement-load-event.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/cssom/HTMLStyleElement-load-event.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/cssom/HTMLStyleElement-load-event.html')
-rw-r--r--testing/web-platform/tests/css/cssom/HTMLStyleElement-load-event.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/HTMLStyleElement-load-event.html b/testing/web-platform/tests/css/cssom/HTMLStyleElement-load-event.html
new file mode 100644
index 0000000000..8d4062ed0d
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/HTMLStyleElement-load-event.html
@@ -0,0 +1,23 @@
+<!doctype html>
+<meta charset="utf-8">
+<title>style elements fire load events properly</title>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="author" title="Mozilla" href="https://mozilla.org">
+<link rel="help" href="https://html.spec.whatwg.org/#update-a-style-block">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script>
+ let NUM_LOADS = 0;
+</script>
+<style onload="++NUM_LOADS"></style>
+<style onload="++NUM_LOADS">:root { background-color: lime }</style>
+<style onload="++NUM_LOADS">:root { background-color: lime }</style> <!-- Intentionally the same -->
+<script>
+async_test(function(t) {
+ assert_equals(document.styleSheets.length, 3, "Should expose the three stylesheets to the OM sync");
+ assert_equals(NUM_LOADS, 0, "Should not fire load event sync");
+ window.addEventListener("load", t.step_func_done(() => {
+ assert_equals(NUM_LOADS, 3, "Load event should've fired for all nodes");
+ }));
+});
+</script>