summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/base-uri.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/css/cssom/base-uri.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/cssom/base-uri.html')
-rw-r--r--testing/web-platform/tests/css/cssom/base-uri.html55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/base-uri.html b/testing/web-platform/tests/css/cssom/base-uri.html
new file mode 100644
index 0000000000..b948d5a7f4
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/base-uri.html
@@ -0,0 +1,55 @@
+<!doctype html>
+<meta charset="utf-8">
+<title>CSSOM base URI is the document's base URI</title>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="author" title="Mozilla" href="https://mozilla.org">
+<link rel="help" href="https://html.spec.whatwg.org/#document-base-url">
+<link rel="help" href="https://bugzilla.mozilla.org/show_bug.cgi?id=1343919">
+<base href="/non-existent-base/">
+<script src='/resources/testharness.js'></script>
+<script src='/resources/testharnessreport.js'></script>
+<div id="target"></div>
+<script>
+const target = document.getElementById("target");
+const kRelativeURI = "url(something.png)";
+const kKeyframes = [
+ { backgroundImage: kRelativeURI },
+ { backgroundImage: kRelativeURI },
+];
+function assertBackground() {
+ const image = getComputedStyle(target).backgroundImage;
+ assert_true(image.includes("non-existent-base"), image);
+}
+function assertNoBackground() {
+ const image = getComputedStyle(target).backgroundImage;
+ assert_equals(image, "none");
+}
+
+promise_test(async function() {
+ target.style.backgroundImage = kRelativeURI;
+ assertBackground();
+ target.style.backgroundImage = "";
+ assertNoBackground();
+}, "setProperty");
+
+promise_test(async function() {
+ const keyframe = new KeyframeEffect(target, kKeyframes, 10000);
+ const animation = new Animation(keyframe, document.timeline);
+ animation.play();
+ await animation.ready;
+ assertBackground();
+ animation.cancel();
+ assertNoBackground();
+}, "KeyframeEffect constructor");
+
+promise_test(async function() {
+ const keyframe = new KeyframeEffect(target, [], 10000);
+ keyframe.setKeyframes(kKeyframes);
+ const animation = new Animation(keyframe, document.timeline);
+ animation.play();
+ await animation.ready;
+ assertBackground();
+ animation.cancel();
+ assertNoBackground();
+}, "KeyframeEffect.setKeyframes");
+</script>