summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/dom/attributes-are-nodes.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/dom/attributes-are-nodes.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/dom/attributes-are-nodes.html')
-rw-r--r--testing/web-platform/tests/dom/attributes-are-nodes.html55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/web-platform/tests/dom/attributes-are-nodes.html b/testing/web-platform/tests/dom/attributes-are-nodes.html
new file mode 100644
index 0000000000..54ff4ccaec
--- /dev/null
+++ b/testing/web-platform/tests/dom/attributes-are-nodes.html
@@ -0,0 +1,55 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>Attributes are Nodes but should not be accepted outside of the `attributes` NamedNodeMap</title>
+<link rel=help href="https://dom.spec.whatwg.org/#dom-core-changes">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+<script>
+"use strict";
+
+test(() => {
+
+ const attribute = document.createAttribute("newattribute");
+
+ assert_true(attribute instanceof Node, "attribute instances are instances of Node");
+ assert_true(Attr.prototype instanceof Node, "attribute instances are instances of Node");
+
+}, "Attrs are subclasses of Nodes");
+
+test(() => {
+
+ const parent = document.createElement("p");
+
+ const attribute = document.createAttribute("newattribute");
+ assert_throws_dom("HierarchyRequestError", () => {
+ parent.appendChild(attribute);
+ });
+
+}, "appendChild with an attribute as the child should fail");
+
+test(() => {
+
+ const parent = document.createElement("p");
+ parent.appendChild(document.createElement("span"));
+
+ const attribute = document.createAttribute("newattribute");
+ assert_throws_dom("HierarchyRequestError", () => {
+ parent.replaceChild(attribute, parent.firstChild);
+ });
+
+}, "replaceChild with an attribute as the child should fail");
+
+test(() => {
+
+ const parent = document.createElement("p");
+ parent.appendChild(document.createElement("span"));
+
+ const attribute = document.createAttribute("newattribute");
+ assert_throws_dom("HierarchyRequestError", () => {
+ parent.insertBefore(attribute, parent.firstChild);
+ });
+
+}, "insertBefore with an attribute as the child should fail");
+
+</script>