summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/focus/focus-large-element-in-overflow-hidden-container-ref.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/focus/focus-large-element-in-overflow-hidden-container-ref.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/focus/focus-large-element-in-overflow-hidden-container-ref.html')
-rw-r--r--testing/web-platform/tests/focus/focus-large-element-in-overflow-hidden-container-ref.html47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/web-platform/tests/focus/focus-large-element-in-overflow-hidden-container-ref.html b/testing/web-platform/tests/focus/focus-large-element-in-overflow-hidden-container-ref.html
new file mode 100644
index 0000000000..856f7940b6
--- /dev/null
+++ b/testing/web-platform/tests/focus/focus-large-element-in-overflow-hidden-container-ref.html
@@ -0,0 +1,47 @@
+<!DOCTYPE html>
+<html>
+<head>
+<meta charset="UTF-8">
+<meta name="viewport" content="width=device-width,initial-scale=1">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/interaction.html#dom-focus">
+<link rel="help" href="https://bugzilla.mozilla.org/show_bug.cgi?id=1858984">
+<style>
+#overflowHiddenContainer
+{
+ margin: 4px;
+ height: 12px;
+ border: 1px solid black;
+ overflow: hidden;
+ line-height: 25px;
+}
+
+#container
+{
+ position: relative;
+ display: inline-block;
+ width: 30px;
+ height: 10px;
+ vertical-align: text-top;
+}
+
+#visibleTarget
+{
+ position: absolute;
+ inset: 0;
+ height: 15px;
+}
+
+</style>
+</head>
+<body>
+ <div id="overflowHiddenContainer">
+ <label id="container">
+ <div tabindex=0 id="visibleTarget">
+ </div>
+ </label>
+ </div>
+</body>
+<script>
+ visibleTarget.focus();
+</script>
+</html>