summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/inert
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /testing/web-platform/tests/inert
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/inert')
-rw-r--r--testing/web-platform/tests/inert/inert-with-fullscreen-element.html65
-rw-r--r--testing/web-platform/tests/inert/inert-with-modal-dialog-003.html59
2 files changed, 124 insertions, 0 deletions
diff --git a/testing/web-platform/tests/inert/inert-with-fullscreen-element.html b/testing/web-platform/tests/inert/inert-with-fullscreen-element.html
new file mode 100644
index 0000000000..e5ea4138a3
--- /dev/null
+++ b/testing/web-platform/tests/inert/inert-with-fullscreen-element.html
@@ -0,0 +1,65 @@
+<!DOCTYPE html>
+<meta charset="utf-8" />
+<title>Interaction of 'inert' attribute with fullscreen element</title>
+<link rel="author" title="Peng Zhou" href="mailto:zhoupeng.1996@bytedance.com">
+<meta name="assert" content="Checks that fullscreen element inertness from ancestors.">
+<div id="wrapper">
+ wrapper
+ <span>
+ wrapper-child element
+ </span>
+ <div id="fullscreen">
+ fullscreen
+ <span id="child">
+ child
+ </span>
+ </div>
+</div>
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="/resources/testdriver.js"></script>
+<script src="/resources/testdriver-vendor.js"></script>
+<script>
+async function cleanup() {
+ if (document.fullscreenElement) {
+ await document.exitFullscreen();
+ }
+ getSelection().removeAllRanges();
+}
+
+async function setupTest(element, context) {
+ element.inert = true;
+ await test_driver.bless("request full screen");
+ await fullscreen.requestFullscreen();
+ context.add_cleanup(async () => {
+ element.inert = false;
+ await cleanup();
+ });
+}
+
+add_completion_callback(cleanup);
+
+promise_test(async function() {
+ await setupTest(child, this);
+ assert_false(window.find("wrapper"));
+ assert_false(window.find("wrapper-child"));
+ assert_true(window.find("fullscreen"));
+ assert_false(window.find("child"));
+}, "Inner nodes with 'inert' attribute become inert anyways");
+
+promise_test(async function() {
+ await setupTest(fullscreen, this);
+ assert_false(window.find("wrapper"));
+ assert_false(window.find("wrapper-child"));
+ assert_false(window.find("fullscreen"));
+ assert_false(window.find("child"));
+}, "If the fullscreen element has the 'inert' attribute, everything becomes inert");
+
+promise_test(async function() {
+ await setupTest(wrapper, this);
+ assert_false(window.find("wrapper"));
+ assert_false(window.find("wrapper-child"));
+ assert_true(window.find("fullscreen"));
+ assert_true(window.find("child"));
+}, "If an ancestor of the fullscreen element has the 'inert' attribute, the fullscreen element escapes inertness");
+</script> \ No newline at end of file
diff --git a/testing/web-platform/tests/inert/inert-with-modal-dialog-003.html b/testing/web-platform/tests/inert/inert-with-modal-dialog-003.html
new file mode 100644
index 0000000000..2984aa4362
--- /dev/null
+++ b/testing/web-platform/tests/inert/inert-with-modal-dialog-003.html
@@ -0,0 +1,59 @@
+<!DOCTYPE html>
+<meta charset="utf-8" />
+<title>Interaction of 'inert' attribute with modal dialog</title>
+<link rel="author" title="Peng Zhou" href="mailto:zhoupeng.1996@bytedance.com">
+<link rel="help" href="https://html.spec.whatwg.org/multipage/interaction.html#inert">
+<meta name="assert" content="Checks that a modal dialog escapes inertness from ancestors.">
+<div id="log"></div>
+<div id="wrapper">
+ find wrapper
+ <dialog id="dialog">
+ find dialog
+ <span id="child">
+ find child
+ </span>
+ </dialog>
+</div>
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script>
+function cleanup() {
+ dialog.close();
+ getSelection().removeAllRanges();
+}
+
+function setupTest(element, context) {
+ element.inert = true;
+ dialog.showModal();
+ context.add_cleanup(() => {
+ element.inert = false;
+ cleanup();
+ });
+}
+
+setup(() => {
+ dialog.showModal();
+ add_completion_callback(cleanup);
+});
+
+test(function() {
+ setupTest(child, this);
+ assert_false(window.find("wrapper"));
+ assert_true(window.find("dialog"));
+ assert_false(window.find("child"));
+}, "Inner nodes with 'inert' attribute become inert anyways");
+
+test(function() {
+ setupTest(dialog, this);
+ assert_false(window.find("wrapper"));
+ assert_false(window.find("dialog"));
+ assert_false(window.find("child"));
+}, "If the modal dialog has the 'inert' attribute, everything becomes inert");
+
+test(function() {
+ setupTest(wrapper, this);
+ assert_false(window.find("wrapper"));
+ assert_true(window.find("dialog"));
+ assert_true(window.find("child"));
+}, "If an ancestor of the dialog has the 'inert' attribute, the dialog escapes inertness");
+</script> \ No newline at end of file