summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/notifications/idlharness.https.any.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/notifications/idlharness.https.any.js
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/notifications/idlharness.https.any.js')
-rw-r--r--testing/web-platform/tests/notifications/idlharness.https.any.js31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/web-platform/tests/notifications/idlharness.https.any.js b/testing/web-platform/tests/notifications/idlharness.https.any.js
new file mode 100644
index 0000000000..e3afe2c219
--- /dev/null
+++ b/testing/web-platform/tests/notifications/idlharness.https.any.js
@@ -0,0 +1,31 @@
+// META: global=window,worker
+// META: script=/resources/WebIDLParser.js
+// META: script=/resources/idlharness.js
+
+'use strict';
+
+// https://notifications.spec.whatwg.org/
+
+idl_test(
+ ['notifications'],
+ ['service-workers', 'hr-time', 'html', 'dom'],
+ idl_array => {
+ if (self.ServiceWorkerGlobalScope) {
+ idl_array.add_objects({
+ ServiceWorkerGlobalScope: ['self'],
+ });
+ // NotificationEvent could be tested here, but the constructor requires
+ // a Notification instance which cannot be created in a service worker,
+ // see below.
+ } else {
+ // While the Notification interface is exposed in service workers, the
+ // constructor (https://notifications.spec.whatwg.org/#dom-notification-notification)
+ // is defined to throw a TypeError. Therefore, we only add the object in
+ // the other scopes.
+ idl_array.add_objects({
+ Notification: ['notification'],
+ });
+ self.notification = new Notification('title');
+ }
+ }
+);