summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/quirks/body-fills-html-quirk.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/quirks/body-fills-html-quirk.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/quirks/body-fills-html-quirk.html')
-rw-r--r--testing/web-platform/tests/quirks/body-fills-html-quirk.html22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/web-platform/tests/quirks/body-fills-html-quirk.html b/testing/web-platform/tests/quirks/body-fills-html-quirk.html
new file mode 100644
index 0000000000..83ccea7dca
--- /dev/null
+++ b/testing/web-platform/tests/quirks/body-fills-html-quirk.html
@@ -0,0 +1,22 @@
+<!DOCTYPE quirks-mode>
+<link rel="help" href="https://quirks.spec.whatwg.org/#the-body-element-fills-the-html-element-quirk"/>
+<link rel="match" href="body-fills-html-quirk-ref2.html" />
+<style>
+ html {
+ width: 200px;
+ height: 200px;
+ }
+ body {
+ border: solid;
+ margin: 10px 11px 12px 14px;
+ }
+ span {
+ display: inline-block;
+ width: 100px;
+ height: 100px;
+ background: green;
+ }
+</style>
+<body>
+ <span></span>
+</body>