summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/quirks/line-height-limited-quirks-mode.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/quirks/line-height-limited-quirks-mode.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/quirks/line-height-limited-quirks-mode.html')
-rw-r--r--testing/web-platform/tests/quirks/line-height-limited-quirks-mode.html26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/web-platform/tests/quirks/line-height-limited-quirks-mode.html b/testing/web-platform/tests/quirks/line-height-limited-quirks-mode.html
new file mode 100644
index 0000000000..db0c3fa2b4
--- /dev/null
+++ b/testing/web-platform/tests/quirks/line-height-limited-quirks-mode.html
@@ -0,0 +1,26 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
+<html>
+<head>
+ <link rel="author" title="Mats Palmgren" href="mailto:mats@mozilla.com">
+ <link rel="help" href="https://quirks.spec.whatwg.org/#the-line-height-calculation-quirk">
+ <link rel="help" href="https://bugzilla.mozilla.org/show_bug.cgi?id=1686326">
+ <link rel="match" href="line-height-ref.html">
+ <meta name="assert" content="The test passes if the blue box has no scrollbar and you see the word PASS">
+<style>
+html,body {
+ color:black; background-color:white; font:20px/1 monospace; padding:0; margin:0;
+}
+
+.wrapper {
+ overflow: auto;
+ border: solid blue;
+}
+</style>
+</head>
+<body>
+ <div class="wrapper">
+ <div style="border:50px solid lightgrey"></div>
+ <span style="margin-top: -100px; display: inline-block">PASS</span>
+ </div>
+</body>
+</html>