summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/quirks/percentage-height-quirk-excludes-flex-grid-001.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/quirks/percentage-height-quirk-excludes-flex-grid-001.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/quirks/percentage-height-quirk-excludes-flex-grid-001.html')
-rw-r--r--testing/web-platform/tests/quirks/percentage-height-quirk-excludes-flex-grid-001.html78
1 files changed, 78 insertions, 0 deletions
diff --git a/testing/web-platform/tests/quirks/percentage-height-quirk-excludes-flex-grid-001.html b/testing/web-platform/tests/quirks/percentage-height-quirk-excludes-flex-grid-001.html
new file mode 100644
index 0000000000..cb0f772b1f
--- /dev/null
+++ b/testing/web-platform/tests/quirks/percentage-height-quirk-excludes-flex-grid-001.html
@@ -0,0 +1,78 @@
+<html>
+<head>
+ <meta charset="utf-8">
+ <title>Test: Percent height quirk does not traverse flex/grid containers</title>
+ <link rel="author" title="Daniel Holbert" href="mailto:dholbert@mozilla.com">
+ <link rel="author" href="https://mozilla.org" title="Mozilla">
+ <link rel="help" href="https://quirks.spec.whatwg.org/#the-percentage-height-calculation-quirk">
+ <link rel="match" href="reference/percentage-height-quirk-excludes-flex-grid-001-ref.html">
+ <meta name="assert" content="This quirk is specific to block boxes and table wrapper boxes; if it hits another type of box, it doesn't traverse further. So this file should look the same whether in quirks or standards mode.">
+ <style>
+ .fixed-height-outer {
+ height: 80px;
+ border: 1px solid gray;
+ margin-bottom: 5px;
+ }
+
+ .row-flex {
+ display: flex;
+ flex-direction: row
+ }
+
+ .column-flex {
+ display: flex;
+ flex-direction: column
+ }
+
+ .grid {
+ display: grid;
+ }
+
+ .container {
+ border: 3px solid black;
+ }
+
+ .pct {
+ height: 75%;
+ min-height: 10px;
+ width: 50px;
+ display: inline-block;
+ vertical-align: top;
+ background: purple;
+ }
+ .px {
+ height: 50px;
+ width: 50px;
+ display: inline-block;
+ vertical-align: top;
+ background: blue
+ }
+ </style>
+</head>
+<body>
+ <div class="fixed-height-outer">
+ <div class="container column-flex">
+ <div>
+ <div class="pct"></div>
+ <div class="px"></div>
+ </div>
+ </div>
+ </div>
+ <div class="fixed-height-outer">
+ <div class="container row-flex">
+ <div>
+ <div class="pct"></div>
+ <div class="px"></div>
+ </div>
+ </div>
+ </div>
+ <div class="fixed-height-outer">
+ <div class="container grid">
+ <div>
+ <div class="pct"></div>
+ <div class="px"></div>
+ </div>
+ </div>
+ </div>
+</body>
+</html>