summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/shadow-dom/declarative/declarative-shadow-dom-available-to-element-internals.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/shadow-dom/declarative/declarative-shadow-dom-available-to-element-internals.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/shadow-dom/declarative/declarative-shadow-dom-available-to-element-internals.html')
-rw-r--r--testing/web-platform/tests/shadow-dom/declarative/declarative-shadow-dom-available-to-element-internals.html30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/web-platform/tests/shadow-dom/declarative/declarative-shadow-dom-available-to-element-internals.html b/testing/web-platform/tests/shadow-dom/declarative/declarative-shadow-dom-available-to-element-internals.html
new file mode 100644
index 0000000000..16fe6fd1d5
--- /dev/null
+++ b/testing/web-platform/tests/shadow-dom/declarative/declarative-shadow-dom-available-to-element-internals.html
@@ -0,0 +1,30 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>Declarative Shadow DOM</title>
+<link rel="author" href="mailto:avandolder@mozilla.com">
+<link rel="help" href="https://html.spec.whatwg.org/#parsing-main-inhead:available-to-element-internals">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+<custom-element>
+ <template shadowrootmode="open">
+ </template>
+</custom-element>
+
+<script>
+ let elementInternals;
+ customElements.define("custom-element", class extends HTMLElement {
+ constructor() {
+ super();
+ elementInternals = this.attachInternals();
+ }
+ });
+
+ window.onload = () => {
+ test(() => {
+ assert_true(!!elementInternals);
+ assert_true(!!elementInternals.shadowRoot);
+ assert_equals(elementInternals.shadowRoot, document.querySelector("custom-element").shadowRoot);
+ }, "Declarative Shadow DOM: shadow root should be available to element internals");
+ };
+</script>