summaryrefslogtreecommitdiffstats
path: root/third_party/jpeg-xl/flake.nix
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/jpeg-xl/flake.nix
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/jpeg-xl/flake.nix')
-rw-r--r--third_party/jpeg-xl/flake.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/jpeg-xl/flake.nix b/third_party/jpeg-xl/flake.nix
new file mode 100644
index 0000000000..4832f5b144
--- /dev/null
+++ b/third_party/jpeg-xl/flake.nix
@@ -0,0 +1,39 @@
+{
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem
+ (system:
+ let
+ pkgs = import nixpkgs {
+ inherit system;
+ };
+ in
+ with pkgs;
+ {
+ devShells.default = mkShell {
+ buildInputs = [
+ clang
+ cmake
+ pkg-config
+ gtest
+ gmock
+ doxygen
+ graphviz
+ python3
+ libclang.python
+ libpng
+ giflib
+ lcms2
+ brotli
+ ];
+ shellHook = ''
+ export CC=clang
+ export CXX=clang++
+ '';
+ };
+ }
+ );
+}