summaryrefslogtreecommitdiffstats
path: root/third_party/libwebrtc/tools/grit/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/libwebrtc/tools/grit/setup.py
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/libwebrtc/tools/grit/setup.py')
-rw-r--r--third_party/libwebrtc/tools/grit/setup.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/libwebrtc/tools/grit/setup.py b/third_party/libwebrtc/tools/grit/setup.py
new file mode 100644
index 0000000000..5d86dfc2fc
--- /dev/null
+++ b/third_party/libwebrtc/tools/grit/setup.py
@@ -0,0 +1,46 @@
+#!/usr/bin/env python3
+# Copyright 2020 The Chromium Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+"""Install the package!"""
+
+from __future__ import absolute_import
+
+import setuptools
+
+
+setuptools.setup(
+ name='grit',
+ version='0',
+ entry_points={
+ 'console_scripts': ['grit = grit.grit_runner:Main'],
+ },
+ packages=setuptools.find_packages(),
+ install_requires=[
+ 'six >= 1.10',
+ ],
+ author='The Chromium Authors',
+ author_email='chromium-dev@chromium.org',
+ description='Google Resource and Internationalization Tool for managing '
+ 'translations & resource files',
+ license='BSD-3',
+ url='https://chromium.googlesource.com/chromium/src/tools/grit/',
+ classifiers=[
+ 'Development Status :: 6 - Mature',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: MacOS',
+ 'Operating System :: Microsoft :: Windows',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Topic :: Utilities',
+ ],
+)