summaryrefslogtreecommitdiffstats
path: root/third_party/python/esprima/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/python/esprima/setup.py
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/esprima/setup.py')
-rw-r--r--third_party/python/esprima/setup.py55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/python/esprima/setup.py b/third_party/python/esprima/setup.py
new file mode 100644
index 0000000000..a28ff7e127
--- /dev/null
+++ b/third_party/python/esprima/setup.py
@@ -0,0 +1,55 @@
+# -*- coding: utf-8 -*-
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+import os
+
+from esprima import version
+
+
+def read(fname):
+ try:
+ with open(os.path.join(os.path.dirname(__file__), fname), "r") as fp:
+ return fp.read().strip()
+ except IOError:
+ return ''
+
+
+setup(
+ name="esprima",
+ version=version,
+ author="German M. Bravo (Kronuz)",
+ author_email="german.mb@gmail.com",
+ url="https://github.com/Kronuz/esprima-python",
+ license="BSD License",
+ keywords="esprima ecmascript javascript parser ast",
+ description="ECMAScript parsing infrastructure for multipurpose analysis in Python",
+ long_description=read("README.rst"),
+ packages=["esprima"],
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Topic :: Software Development :: Code Generators",
+ "Topic :: Software Development :: Compilers",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Text Processing :: General",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ ],
+ entry_points={
+ 'console_scripts': [
+ 'esprima = esprima.__main__:main',
+ ]
+ },
+)