summaryrefslogtreecommitdiffstats
path: root/third_party/python/toml/toml-0.10.2.dist-info
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/python/toml/toml-0.10.2.dist-info
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/toml/toml-0.10.2.dist-info')
-rw-r--r--third_party/python/toml/toml-0.10.2.dist-info/LICENSE27
-rw-r--r--third_party/python/toml/toml-0.10.2.dist-info/METADATA255
-rw-r--r--third_party/python/toml/toml-0.10.2.dist-info/RECORD10
-rw-r--r--third_party/python/toml/toml-0.10.2.dist-info/WHEEL6
-rw-r--r--third_party/python/toml/toml-0.10.2.dist-info/top_level.txt1
5 files changed, 299 insertions, 0 deletions
diff --git a/third_party/python/toml/toml-0.10.2.dist-info/LICENSE b/third_party/python/toml/toml-0.10.2.dist-info/LICENSE
new file mode 100644
index 0000000000..5010e3075e
--- /dev/null
+++ b/third_party/python/toml/toml-0.10.2.dist-info/LICENSE
@@ -0,0 +1,27 @@
+The MIT License
+
+Copyright 2013-2019 William Pearson
+Copyright 2015-2016 Julien Enselme
+Copyright 2016 Google Inc.
+Copyright 2017 Samuel Vasko
+Copyright 2017 Nate Prewitt
+Copyright 2017 Jack Evans
+Copyright 2019 Filippo Broggini
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE. \ No newline at end of file
diff --git a/third_party/python/toml/toml-0.10.2.dist-info/METADATA b/third_party/python/toml/toml-0.10.2.dist-info/METADATA
new file mode 100644
index 0000000000..6f2635ce4d
--- /dev/null
+++ b/third_party/python/toml/toml-0.10.2.dist-info/METADATA
@@ -0,0 +1,255 @@
+Metadata-Version: 2.1
+Name: toml
+Version: 0.10.2
+Summary: Python Library for Tom's Obvious, Minimal Language
+Home-page: https://github.com/uiri/toml
+Author: William Pearson
+Author-email: uiri@xqz.ca
+License: MIT
+Platform: UNKNOWN
+Classifier: Development Status :: 5 - Production/Stable
+Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: MIT License
+Classifier: Operating System :: OS Independent
+Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 2
+Classifier: Programming Language :: Python :: 2.6
+Classifier: Programming Language :: Python :: 2.7
+Classifier: Programming Language :: Python :: 3
+Classifier: Programming Language :: Python :: 3.3
+Classifier: Programming Language :: Python :: 3.4
+Classifier: Programming Language :: Python :: 3.5
+Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: 3.7
+Classifier: Programming Language :: Python :: 3.8
+Classifier: Programming Language :: Python :: 3.9
+Classifier: Programming Language :: Python :: Implementation :: CPython
+Classifier: Programming Language :: Python :: Implementation :: PyPy
+Requires-Python: >=2.6, !=3.0.*, !=3.1.*, !=3.2.*
+
+****
+TOML
+****
+
+.. image:: https://img.shields.io/pypi/v/toml
+ :target: https://pypi.org/project/toml/
+
+.. image:: https://travis-ci.org/uiri/toml.svg?branch=master
+ :target: https://travis-ci.org/uiri/toml
+
+.. image:: https://img.shields.io/pypi/pyversions/toml.svg
+ :target: https://pypi.org/project/toml/
+
+
+A Python library for parsing and creating `TOML <https://en.wikipedia.org/wiki/TOML>`_.
+
+The module passes `the TOML test suite <https://github.com/BurntSushi/toml-test>`_.
+
+See also:
+
+* `The TOML Standard <https://github.com/toml-lang/toml>`_
+* `The currently supported TOML specification <https://github.com/toml-lang/toml/blob/v0.5.0/README.md>`_
+
+Installation
+============
+
+To install the latest release on `PyPI <https://pypi.org/project/toml/>`_,
+simply run:
+
+::
+
+ pip install toml
+
+Or to install the latest development version, run:
+
+::
+
+ git clone https://github.com/uiri/toml.git
+ cd toml
+ python setup.py install
+
+Quick Tutorial
+==============
+
+*toml.loads* takes in a string containing standard TOML-formatted data and
+returns a dictionary containing the parsed data.
+
+.. code:: pycon
+
+ >>> import toml
+ >>> toml_string = """
+ ... # This is a TOML document.
+ ...
+ ... title = "TOML Example"
+ ...
+ ... [owner]
+ ... name = "Tom Preston-Werner"
+ ... dob = 1979-05-27T07:32:00-08:00 # First class dates
+ ...
+ ... [database]
+ ... server = "192.168.1.1"
+ ... ports = [ 8001, 8001, 8002 ]
+ ... connection_max = 5000
+ ... enabled = true
+ ...
+ ... [servers]
+ ...
+ ... # Indentation (tabs and/or spaces) is allowed but not required
+ ... [servers.alpha]
+ ... ip = "10.0.0.1"
+ ... dc = "eqdc10"
+ ...
+ ... [servers.beta]
+ ... ip = "10.0.0.2"
+ ... dc = "eqdc10"
+ ...
+ ... [clients]
+ ... data = [ ["gamma", "delta"], [1, 2] ]
+ ...
+ ... # Line breaks are OK when inside arrays
+ ... hosts = [
+ ... "alpha",
+ ... "omega"
+ ... ]
+ ... """
+ >>> parsed_toml = toml.loads(toml_string)
+
+
+*toml.dumps* takes a dictionary and returns a string containing the
+corresponding TOML-formatted data.
+
+.. code:: pycon
+
+ >>> new_toml_string = toml.dumps(parsed_toml)
+ >>> print(new_toml_string)
+ title = "TOML Example"
+ [owner]
+ name = "Tom Preston-Werner"
+ dob = 1979-05-27T07:32:00Z
+ [database]
+ server = "192.168.1.1"
+ ports = [ 8001, 8001, 8002,]
+ connection_max = 5000
+ enabled = true
+ [clients]
+ data = [ [ "gamma", "delta",], [ 1, 2,],]
+ hosts = [ "alpha", "omega",]
+ [servers.alpha]
+ ip = "10.0.0.1"
+ dc = "eqdc10"
+ [servers.beta]
+ ip = "10.0.0.2"
+ dc = "eqdc10"
+
+*toml.dump* takes a dictionary and a file descriptor and returns a string containing the
+corresponding TOML-formatted data.
+
+.. code:: pycon
+
+ >>> with open('new_toml_file.toml', 'w') as f:
+ ... new_toml_string = toml.dump(parsed_toml, f)
+ >>> print(new_toml_string)
+ title = "TOML Example"
+ [owner]
+ name = "Tom Preston-Werner"
+ dob = 1979-05-27T07:32:00Z
+ [database]
+ server = "192.168.1.1"
+ ports = [ 8001, 8001, 8002,]
+ connection_max = 5000
+ enabled = true
+ [clients]
+ data = [ [ "gamma", "delta",], [ 1, 2,],]
+ hosts = [ "alpha", "omega",]
+ [servers.alpha]
+ ip = "10.0.0.1"
+ dc = "eqdc10"
+ [servers.beta]
+ ip = "10.0.0.2"
+ dc = "eqdc10"
+
+For more functions, view the API Reference below.
+
+Note
+----
+
+For Numpy users, by default the data types ``np.floatX`` will not be translated to floats by toml, but will instead be encoded as strings. To get around this, specify the ``TomlNumpyEncoder`` when saving your data.
+
+.. code:: pycon
+
+ >>> import toml
+ >>> import numpy as np
+ >>> a = np.arange(0, 10, dtype=np.double)
+ >>> output = {'a': a}
+ >>> toml.dumps(output)
+ 'a = [ "0.0", "1.0", "2.0", "3.0", "4.0", "5.0", "6.0", "7.0", "8.0", "9.0",]\n'
+ >>> toml.dumps(output, encoder=toml.TomlNumpyEncoder())
+ 'a = [ 0.0, 1.0, 2.0, 3.0, 4.0, 5.0, 6.0, 7.0, 8.0, 9.0,]\n'
+
+API Reference
+=============
+
+``toml.load(f, _dict=dict)``
+ Parse a file or a list of files as TOML and return a dictionary.
+
+ :Args:
+ * ``f``: A path to a file, list of filepaths (to be read into single
+ object) or a file descriptor
+ * ``_dict``: The class of the dictionary object to be returned
+
+ :Returns:
+ A dictionary (or object ``_dict``) containing parsed TOML data
+
+ :Raises:
+ * ``TypeError``: When ``f`` is an invalid type or is a list containing
+ invalid types
+ * ``TomlDecodeError``: When an error occurs while decoding the file(s)
+
+``toml.loads(s, _dict=dict)``
+ Parse a TOML-formatted string to a dictionary.
+
+ :Args:
+ * ``s``: The TOML-formatted string to be parsed
+ * ``_dict``: Specifies the class of the returned toml dictionary
+
+ :Returns:
+ A dictionary (or object ``_dict``) containing parsed TOML data
+
+ :Raises:
+ * ``TypeError``: When a non-string object is passed
+ * ``TomlDecodeError``: When an error occurs while decoding the
+ TOML-formatted string
+
+``toml.dump(o, f, encoder=None)``
+ Write a dictionary to a file containing TOML-formatted data
+
+ :Args:
+ * ``o``: An object to be converted into TOML
+ * ``f``: A File descriptor where the TOML-formatted output should be stored
+ * ``encoder``: An instance of ``TomlEncoder`` (or subclass) for encoding the object. If ``None``, will default to ``TomlEncoder``
+
+ :Returns:
+ A string containing the TOML-formatted data corresponding to object ``o``
+
+ :Raises:
+ * ``TypeError``: When anything other than file descriptor is passed
+
+``toml.dumps(o, encoder=None)``
+ Create a TOML-formatted string from an input object
+
+ :Args:
+ * ``o``: An object to be converted into TOML
+ * ``encoder``: An instance of ``TomlEncoder`` (or subclass) for encoding the object. If ``None``, will default to ``TomlEncoder``
+
+ :Returns:
+ A string containing the TOML-formatted data corresponding to object ``o``
+
+
+
+Licensing
+=========
+
+This project is released under the terms of the MIT Open Source License. View
+*LICENSE.txt* for more information.
+
+
diff --git a/third_party/python/toml/toml-0.10.2.dist-info/RECORD b/third_party/python/toml/toml-0.10.2.dist-info/RECORD
new file mode 100644
index 0000000000..6b3a3a604d
--- /dev/null
+++ b/third_party/python/toml/toml-0.10.2.dist-info/RECORD
@@ -0,0 +1,10 @@
+toml/__init__.py,sha256=Au3kqCwKD0cjbf4yJGOpUFwpsY0WHsC1ZRGvWgIKmpc,723
+toml/decoder.py,sha256=hSGTLf-2WBDZ_ddoCHWFy6N647XyMSh1o3rN2o4dEFg,38942
+toml/encoder.py,sha256=XjBc8ayvvlsLyd_qDA4tMWDNmMFRS4DpwtuDSWBq7zo,9940
+toml/ordered.py,sha256=mz03lZmV0bmc9lsYRIUOuj7Dsu5Ptwq-UtGVq5FdVZ4,354
+toml/tz.py,sha256=-5vg8wkg_atnVi2TnEveexIVE7T_FxBVr_-2WVfO1oA,701
+toml-0.10.2.dist-info/LICENSE,sha256=LZKUgj32yJNXyL5JJ_znk2HWVh5e51MtWSbmOTmqpTY,1252
+toml-0.10.2.dist-info/METADATA,sha256=n_YkspvEihd_QXLIZZ50WVSFz3rZ_k7jQP-OU1WUpWY,7142
+toml-0.10.2.dist-info/WHEEL,sha256=ADKeyaGyKF5DwBNE0sRE5pvW-bSkFMJfBuhzZ3rceP4,110
+toml-0.10.2.dist-info/top_level.txt,sha256=2BO8ZRNnvJWgXyiQv66LBb_v87qBzcoUtEBefA75Ouk,5
+toml-0.10.2.dist-info/RECORD,,
diff --git a/third_party/python/toml/toml-0.10.2.dist-info/WHEEL b/third_party/python/toml/toml-0.10.2.dist-info/WHEEL
new file mode 100644
index 0000000000..6d38aa0601
--- /dev/null
+++ b/third_party/python/toml/toml-0.10.2.dist-info/WHEEL
@@ -0,0 +1,6 @@
+Wheel-Version: 1.0
+Generator: bdist_wheel (0.35.1)
+Root-Is-Purelib: true
+Tag: py2-none-any
+Tag: py3-none-any
+
diff --git a/third_party/python/toml/toml-0.10.2.dist-info/top_level.txt b/third_party/python/toml/toml-0.10.2.dist-info/top_level.txt
new file mode 100644
index 0000000000..bd79a658fe
--- /dev/null
+++ b/third_party/python/toml/toml-0.10.2.dist-info/top_level.txt
@@ -0,0 +1 @@
+toml