summaryrefslogtreecommitdiffstats
path: root/third_party/rust/audio_thread_priority/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/audio_thread_priority/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/audio_thread_priority/Cargo.toml')
-rw-r--r--third_party/rust/audio_thread_priority/Cargo.toml65
1 files changed, 65 insertions, 0 deletions
diff --git a/third_party/rust/audio_thread_priority/Cargo.toml b/third_party/rust/audio_thread_priority/Cargo.toml
new file mode 100644
index 0000000000..30861cdafd
--- /dev/null
+++ b/third_party/rust/audio_thread_priority/Cargo.toml
@@ -0,0 +1,65 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "audio_thread_priority"
+version = "0.31.0"
+authors = ["Paul Adenot <paul@paul.cx>"]
+description = "Bump a thread to real-time priority, for audio work, on Linux, Windows and macOS"
+readme = "README.md"
+license = "MPL-2.0"
+repository = "https://github.com/padenot/audio_thread_priority"
+
+[lib]
+name = "audio_thread_priority"
+crate-type = [
+ "staticlib",
+ "rlib",
+]
+
+[dependencies.cfg-if]
+version = "1.0"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.simple_logger]
+version = "0.4"
+optional = true
+
+[dev-dependencies.nix]
+version = "0.26"
+
+[features]
+default = ["with_dbus"]
+terminal-logging = ["simple_logger"]
+with_dbus = ["dbus"]
+
+[target."cfg(target_os = \"linux\")".dependencies.dbus]
+version = "0.6.4"
+optional = true
+
+[target."cfg(target_os = \"linux\")".dependencies.libc]
+version = "0.2"
+
+[target."cfg(target_os = \"macos\")".dependencies.libc]
+version = "0.2"
+
+[target."cfg(target_os = \"macos\")".dependencies.mach]
+version = "0.3"
+
+[target."cfg(target_os = \"windows\")".dependencies.windows-sys]
+version = "0.52"
+features = [
+ "Win32_Foundation",
+ "Win32_System_Threading",
+]