summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bindgen/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/bindgen/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/bindgen/Cargo.toml')
-rw-r--r--third_party/rust/bindgen/Cargo.toml151
1 files changed, 151 insertions, 0 deletions
diff --git a/third_party/rust/bindgen/Cargo.toml b/third_party/rust/bindgen/Cargo.toml
new file mode 100644
index 0000000000..c4f5f568ae
--- /dev/null
+++ b/third_party/rust/bindgen/Cargo.toml
@@ -0,0 +1,151 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.60.0"
+name = "bindgen"
+version = "0.69.4"
+authors = [
+ "Jyun-Yan You <jyyou.tw@gmail.com>",
+ "Emilio Cobos Álvarez <emilio@crisal.io>",
+ "Nick Fitzgerald <fitzgen@gmail.com>",
+ "The Servo project developers",
+]
+build = "build.rs"
+description = "Automatically generates Rust FFI bindings to C and C++ libraries."
+homepage = "https://rust-lang.github.io/rust-bindgen/"
+documentation = "https://docs.rs/bindgen"
+readme = "README.md"
+keywords = [
+ "bindings",
+ "ffi",
+ "code-generation",
+]
+categories = [
+ "external-ffi-bindings",
+ "development-tools::ffi",
+]
+license = "BSD-3-Clause"
+repository = "https://github.com/rust-lang/rust-bindgen"
+
+[package.metadata.docs.rs]
+features = ["experimental"]
+
+[package.metadata.release]
+pre-release-hook = [
+ "../node_modules/doctoc/doctoc.js",
+ "../CHANGELOG.md",
+]
+release = true
+
+[[package.metadata.release.pre-release-replacements]]
+file = "../CHANGELOG.md"
+replace = """
+# Unreleased
+## Added
+## Changed
+## Removed
+## Fixed
+## Security
+
+# {{version}} ({{date}})"""
+search = "# Unreleased"
+
+[lib]
+name = "bindgen"
+path = "lib.rs"
+
+[dependencies.annotate-snippets]
+version = "0.9.1"
+features = ["color"]
+optional = true
+
+[dependencies.bitflags]
+version = "2.2.1"
+
+[dependencies.cexpr]
+version = "0.6"
+
+[dependencies.clang-sys]
+version = "1"
+features = ["clang_6_0"]
+
+[dependencies.itertools]
+version = ">=0.10,<0.13"
+default-features = false
+
+[dependencies.lazy_static]
+version = "1"
+
+[dependencies.lazycell]
+version = "1"
+
+[dependencies.log]
+version = "0.4"
+optional = true
+
+[dependencies.prettyplease]
+version = "0.2.7"
+features = ["verbatim"]
+optional = true
+
+[dependencies.proc-macro2]
+version = "1"
+default-features = false
+
+[dependencies.quote]
+version = "1"
+default-features = false
+
+[dependencies.regex]
+version = "1.5.1"
+features = [
+ "std",
+ "unicode-perl",
+]
+default-features = false
+
+[dependencies.rustc-hash]
+version = "1.0.1"
+
+[dependencies.shlex]
+version = "1"
+
+[dependencies.syn]
+version = "2.0"
+features = [
+ "full",
+ "extra-traits",
+ "visit-mut",
+]
+
+[dependencies.which]
+version = "4.2.1"
+optional = true
+default-features = false
+
+[features]
+__cli = []
+__testing_only_extra_assertions = []
+__testing_only_libclang_16 = []
+__testing_only_libclang_9 = []
+default = [
+ "logging",
+ "prettyplease",
+ "runtime",
+ "which-rustfmt",
+]
+experimental = ["dep:annotate-snippets"]
+logging = ["dep:log"]
+runtime = ["clang-sys/runtime"]
+static = ["clang-sys/static"]
+which-rustfmt = ["dep:which"]